Ensure master clock

Hello!
How to ensure the value of master clock?

sudo grep aud_mclk /sys/kernel/debug/clk/clk_summary
returns nothing

While decompiling DTB with command
sudo dtc -I fs -O dts -o extracted_proc.dts /proc/device-tree
shows dts with correct value : nvidia,mclk-rate=<0xbb8000>;

that exactly what I need - 12.288MHz

But I suspect that master clock is not 12.288, 'cos when I use external generator with 12.288 I have correct signal from mics, and when I use Jetson internal master clock I get poor signal from mics

Thank you!

Looks like the mclk-rate not define in the default device tree.
I didn’t see the mclk_rate from my nano fro 32.4.3

Thank you for reply!
You mean tree that is elsewhere, for example, in /boot/dtb?
I have 32.4.3 version and thus I should use flash.sh to enable compiled tree, but I can not find flash. sh

I mean I didn’t find the mclk_rate by extracted_proc.dts

sudo dtc -I fs -O dts -o extracted_proc.dts /proc/device-tree

I put
nvidia,mclk-rate=<12288000>;
item in DTB which is referenced from /boot/extlinux/extlinux.conf
maybe why I get that option on a default device tree

Not sure why you add this to dt.
For codec dt configure you can reference to below link.

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide%2Fasoc_driver.18.2.html

I followed that instuctions
https://docs.nvidia.com/jetson/archives/l4t-archived/l4t-3231/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide/asoc_driver.17.2.html

sound {
nvidia,mclk-rate = <mclk_fixed_rate>;
mclk_parent = //optional
};

Thank you for useful link.
I think maybe I should remove scaling factor from dt
mclk-fs = ;

finally set
mclk-fs = <0x300>;
and got 12288000 Hz with sample rate 16000