Entron F008A030BM0A camera

Hi!
Guys, i want to use this camera with new release of driveworks
Entron F008A030BM0A
What is camera-type for it?
Thanks!

Hi mikelb2k0,
the Driveworks 2.2 SAL supported camaera-type strings are mentioned here:
https://docs.nvidia.com/driveworks/camera_mainsection.html

although the Entron F008A030BM0A camera is supported camea hw following here:
https://developer.nvidia.com/drive/drive-core-sensors

Hi!
Frankly, i am confused.
If NVIDIA documentation said that specific Sensor (Camera in that case) is supported, my expectation is that it has SAL for it. But what you are saying is that i have to implement it by myself. What does “support” means in that case?
Also, i was digging in binary files and i have found that some cameras with AR0820 sensor are supported, for example this driver exists: ar0820-rccb-bae-f008a030bm0a.
So, i think, documentation you sent is not up-to-date https://docs.nvidia.com/driveworks/camera_mainsection.html because it is not mentioned there.
Thanks!

Hi mikelb2k0,

you are right, this section of camera is not up-to-date:
https://docs.nvidia.com/driveworks/camera_mainsection.html

the string “ar0820-rccb-bae-f008a030bm0a” as you wrote is the camera-type one to use for your camera.

can you confirm that now you are able to communicate with your camera?

Hi!
Thanks for timely responses, you, guys, do good job.

No, it does not work
Here are experiments i did so far:

Here, it seems that DW creates a new string from parameters but cannot find that string in driver list

Camera params:
“output-format=yuv,fifo-size=3,camera-type=ar0820-rccb-bae-f008a030bm0a,
camera-mask=0001,camera-group=a,slave=0,required-framerate=30,camera-count=1”

Results

DriveWorks: [26-12-2019 19:11:00] DriveWorks: Platform: Detected DDPX - Tegra A
DriveWorks: [26-12-2019 19:11:00] DriveWorks: TimeSource: monotonic epoch time offset is 1576920210874577
DriveWorks: [26-12-2019 19:11:00] DriveWorks: PTP Time is available from NVPPS Driver
DriveWorks: [26-12-2019 19:11:01] DriveWorks: Platform: number of GPU devices detected 1
DriveWorks: [26-12-2019 19:11:01] DriveWorks: Platform: currently selected GPU device integrated ID 0
DriveWorks: [26-12-2019 19:11:01] DriveWorks: SDK: Resource failed to mount from ‘…/’: VirtualFileSystem: Failed to mount ‘…/[.pak]’
DriveWorks: [26-12-2019 19:11:01] DriveWorks: SDK: No resources mounted, some modules will not function properly
DriveWorks: [26-12-2019 19:11:01] DriveWorks: SDK: Create NvMediaDevice
DriveWorks: [26-12-2019 19:11:01] DriveWorks: egl::Display: found 1 EGL devices
DriveWorks: [26-12-2019 19:11:01] DriveWorks: egl::Display: use drm device: drm-nvdc
DriveWorks: [26-12-2019 19:11:01] DriveWorks: TimeSource: monotonic epoch time offset is 1576920210874577
DriveWorks: [26-12-2019 19:11:01] DriveWorks: PTP Time is available from NVPPS Driver
DriveWorks: [26-12-2019 19:11:01] DriveWorks: Initialize DriveWorks SDK v2.2.3136
DriveWorks: [26-12-2019 19:11:01] DriveWorks: Release build with GNU 7.3.1 from heads/buildbrain-branch-0-gca7b4b26e65 against Drive PDK v5.1.6.1

xxxxxxxxxxxxxxxxxxx

DriveWorks: [26-12-2019 19:11:08] DriveWorks: SensorFactory::createSensor() -> camera.gmsl,
output-format=yuv,fifo-size=3,camera-type=ar0820-rccb-bae-f008a030bm0a,
camera-mask=0001,camera-group=a,slave=0,required-framerate=30,camera-count=1
DriveWorks: [26-12-2019 19:11:08] DriveWorks: CameraGMSL: Create NvMediaIPPManager
DriveWorks: [26-12-2019 19:11:08] DriveWorks: CameraGMSL: required FPS = 30, resolution = 3848x2168
nvmedia: ERROR: ImgGetDevice: Can’t find driver for ref_max96712_9295_ar0820f008a030bm0a
DriveWorks: [26-12-2019 19:11:08] DriveWorks: Driveworks exception thrown: DW_SAL_CANNOT_CREATE_SENSOR: CameraGMSL: cannot connect to camera
DriveWorks:
error at xxx.cpp at 414 line dwSAL_createSensor failed status = 25

Here I just gave another string with ar0820 and it seems to progress a little bit more
Camera params:
“output-format=yuv,fifo-size=3,camera-type=ar0820-rccb-sim-ddpx,
camera-mask=0001,camera-group=a,slave=0,required-framerate=30,camera-count=1”

Result:
DriveWorks: [6-12-2019 19:16:10] DriveWorks: SensorFactory::createSensor() -> camera.gmsl,
output-format=yuv,fifo-size=3,camera-type=ar0820-rccb-sim-ddpx,
camera-mask=0001,camera-group=a,slave=0,required-framerate=30,camera-count=1
DriveWorks: [26-12-2019 19:16:10] DriveWorks: CameraGMSL: Create NvMediaIPPManager
DriveWorks: [26-12-2019 19:16:10] DriveWorks: CameraGMSL: required FPS = 30, resolution = 3848x2168
nvmedia isc: GetCameraPowerControlLevel: 936: Camera power control library: NVCCP
Max96712 Rev 2 detected!
nvmedia: ERROR: SetupConfigLink: Failed to detect a serializer with a supported revision
nvmedia: ERROR: Init: Failed to setup config link
DriveWorks: [26-12-2019 19:16:11] DriveWorks: Driveworks exception thrown: DW_SAL_CANNOT_CREATE_SENSOR: CameraGMSL: cannot connect to camera

Another aspect that i was trying to understand is if this camera is enabled thru SIPL?
If it is correct, than protocol should be defined with camera.gmsl.master & camera.gmsl.slave
And if it is true, where can i find an example for such configuration?
So, i tried SIPL configuration but still failed
DriveWorks: [27-12-2019 06:44:50] DriveWorks: SensorFactory::createSensor() -> camera.gmsl.master, output-format=yuv,fifo-size=3,camera-type=ar0820-rccb-bae-f008a030bm0a, camera-mask=0001,camera-group=a,slave=0,required-framerate=30,camera-count=1, config-type=platform
libnvsipl_query.so: CNvMCameraModuleInfo.cpp : 76: ParseJson: Could not find matching serializer
libnvsipl_query.so: CNvMDeviceInfoList.cpp : 100: GetCustomCameraModule: Failed to find matching module MAX96712TPG
libnvsipl_query.so: CNvMDeviceBlockInfo.cpp : 156: ParseJson: Failed to find matching camera module
libnvsipl_query.so: CNvMPlatformCfgInfo.cpp : 50: ParseJson: CNvMPlatformCfgInfo::ParseJson failed.
libnvsipl_query.so: CNvMQuery.cpp : 45: ParsePlatformConfig: Failed to parse a PlatformCfg
DriveWorks: [27-12-2019 06:44:50] DriveWorks: CameraGMSLMaster::setupWithPlatform Using platform configuration:
DriveWorks: [27-12-2019 06:44:50] DriveWorks: Driveworks exception thrown: DW_INTERNAL_ERROR: CameraGMSLMaster:: Platform configuration failed! platform string: output-format=yuv,fifo-size=3,camera-type=ar0820-rccb-bae-f008a030bm0a, camera-mask=0001,camera-group=a,slave=0,required-framerate=30,camera-count=1, config-type=platform SIPL errror code = 1

Hi Mikelb2k0,

we are investigating is internally and will update soon.

Hi!
Very well, i will really appreciate quick response in the next couple of days.
Thanks!

Hi mikelb2k0,

The string “ar0820-rccb-bae-f008a030bm0a” you found in the binaries is not enabled in the public release.

Can you please file a bug on this request so we can help support you.

We are working on revising https://developer.nvidia.com/drive/drive-core-sensors to be more accurate. It will be clear what is supported in the general availability releases versus what is supported under special support.
We would expect an update to the website in January.

Hi mikelb2k0,

Were you able to open a bug on this issue? Please let me know if you have any issues with it.

Hi!
Sorry, guys, was very busy. How do i file such a bug?
Thanks!

Please submit the bug via https://developer.nvidia.com/ -> “My account” (https://developer.nvidia.com/user) -> “My Bugs” -> “Submit a New Bug” (https://developer.nvidia.com/nvidia_bug/add). Thanks!

Hey,

January went by a while ago, I am still not sure how to tell if the camera driver is enabled. We struggle with the same issue here, same camera.

Hi @andre.a.bauer,

You can refer to “contact” column in the tables at https://developer.nvidia.com/drive/ecosystem-hw-sw to know from whom to get the associated software/drivers for the supported releases. Thanks!