EOSHIFT dim error

I have tried compiling a routine with pghpf version 5.1 and I get
an error as follows:

pghpf -Mextend -Mmpi -Mhpf2 -Mstats -fast -I. -c grider.hpf
PGHPF-S-0000-Internal compiler error. inline_shifts: variable dim not implemented 1462 (grider.hpf: 382)
PGHPF-S-0155-DIM argument out of range for symbol coord (grider.hpf: 382)
0 inform, 0 warnings, 2 severes, 0 fatal for grider

suggesting that the (optional) fourth argument to EOSHIFT is not recognized.
The same code compiled successfully under pghpf 3.2. Does anyone know if
the more recent releases have un-implemented this parameter ?

Thanks.
[/b]

A very similar a bug was found in our 5.1 compilers and fixed in the 5.2 release (reference TPR 3250). Please download and install the 5.2 release from http://www.pgroup.com/support/download_release.php and the problem should be corrected.

Thanks,
Mat

There are two tprs associated with eoshift.

==================================================================
tpr 3167 – this program failed to produce correct answers before 5.2-4.
It is corrected in 5.2-4
implicit none
integer, parameter :: N=4
integer, dimension(N) :: t,ym,yp
integer :: i
t=(/(i,i=1,N)/)
ym=eoshift(t,-1,0)
yp=eoshift(t,1,0)
print *, ’ t’,t
print *, ‘ym’,ym
print *, ‘yp’,yp
end

====================================================================

tpr 3250 - eoshift does not properly handle the fourth argument properly.
This is currently still not fixed, and will be corrected in the 6.0 release in
Q1.

Further note on the fourth, in principle optional argument dim to EOSHIFT: pghpf5.2 will handle the argument correctly if it is not a variable, but rather simply an integer;

e.g.

test1=EOSHIFT(coord(:,:,:,2), 1, filler, DIM=2)

works fine. But

i1=2
test1=EOSHIFT(coord(:,:,:,i1), 1, filler, DIM=i1)

chokes upon compile.