Error: API mismatch configuration problems

I recently got a GTX 280 GPU, where I want to use CUDA. I’m using ubuntu 7.04 and have been using a Quadro 5600 for quite some time.
When I tried to install the GTX280 (and similarly the Geforce 9800), and I try to use CUDA and CUBLAS, the following error appears:

Error: API mismatch: the NVIDIA kernel module has version 177.13,
but this NVIDIA driver component has version 100.14.11. Please make
sure that the kernel module and all NVIDIA driver components
have the same version.
Error initializing CUBLAS
Error initializing CUBLAS

I have erased some files on /usr that might be old driver components. I hope you guys can have an idea on this problem, because I’ve been trying from different angles without an answer.

Furthermore, I don’t know if I use install ubuntu’s nvidia-glx family of drivers.

Thanks for all the help!!!

just install the latest cuda 2.0 beta drivers from nvidia. They have support for GTX280. I don’t know if you can install them the ubuntu way yet. On FC8 I had to manually install them and prevent FC8 of updating its NVIDIA driver

Oh and make sure you install the corresponding toolkit

That seems to have worked. I was focusing only on the GPU driver, and not on the CUDA one.