Error at Orin with NVMe/emcc Flash in NVMe/emcc and boot from NVMe/emcc

After executing the flash command, an error occurred. The error on the host side is as follows:
flash.log (11.8 KB)
The error on the host side is as follows:
orin.log (25.8 KB)

May I double check you are talking about Orin 32GB module but not Orin 64GB or Orin Nano/NX?

Also, is same command able to flash same module if it is on NV devkit?

We are talking about the orin module, is there a big difference between 32GB and 64GB, I feel the main problem is that the orin serial port log cannot open the device block

Hi,

Since you are using custom board, your hardware design may be the problem here too.

That is why I need to ask did you ever try it on devkit because that is the only baseline that I can guarantee working.

Another reminder that you have to disable cvb eeprom read on custom board.

https://docs.nvidia.com/jetson/archives/r35.4.1/DeveloperGuide/text/HR/JetsonModuleAdaptationAndBringUp/JetsonAgxOrinSeries.html?highlight=cvb#modifying-the-eeprom

We plan to try it on the developer kit tomorrow and synchronize the information with you.
I plan to use this orin module to connect to theboard of the developer kit. Is this possible?

I haven’t did that,i will have a try for this.

Yes it is.

The programming was brought up successful after connecting to the development board. Do you have the circuit diagram of the development board?

Over the download center:

After flashing the machine on the development board, I put the machine on the custom board. It cannot be started, and the bootloader is stuck. The above is the normal orin serial port printing on the development version, and the bottom is the orin serial port printing on the custom board.

As I already told yesterday.

OK,Thanks a lot.After changing this, I need to recompile BootLoader and upgrade it. I haven’t seen instructions for compiling and upgrading BootLoader separately. Is there any corresponding guidance?

I am not sure why you think this needs to compile bootloader… this does not need. That is why document didn’t mention anything further.

Just configure the file and reflash the board and it would take effect.

Thank you very much, it works now on after disable cvb eeprom read on custom board.

1 Like

Hello,wayneWWW.

Configure the switch port mode to XFI 10G. The orin register is unstable and keeps failing and succeeding. Do you know what the problem is?

please file a new topic. We don’t use one topic to track your board forever…

ok,thanks a lot.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.