Error: Black Screen With 'X' Cursor

This morning I turned on the TX1, and it worked fine. I was trying to copy and paste a file from an external hard drive and I received an error message saying that I did not have enough memory. It was after this error message that it froze up, kind of… I was able to move the mouse around, but when I attempted to open an application, it would load but never open the program. I cycled the power, thinking that would be a quick fix.

Now, nothing will come on the screen EXCEPT for a black cursor in the shape of an ‘X’ that behaves normally . There are several things that are happening:

-Green LEDs come on like normal
-The monitor wakes from sleep mode when TX1 is turned on.
-There is an initial loading-screen that shows a bunch of files, drivers, etc. being loaded up.

  • No picture at all after the loading screen.

To troubleshoot, I plugged the TX1 into several other monitors, and I get no picture on all three of them. I’ve tried Ctrl+Alt+F1 and I do not get a terminal to appear. Please help.

I suspect a temporary file or “config on logout” file is at issue. The “X” cursor means X11 is running, it sounds like the window manager died. “Repair” might depend on what got corrupted or truncated.

If a journaling file system gets turned off while something is still writing or cached, theory is that the next boot will keep the structure of the file system in tact…but it may cut out data if this is the case, e.g., all or part of a file or directory which was being written to at the moment of failure. Without this the entire file system could be lost, and not just parts of it.

If you don’t need to rescue anything on the device, it might be easiest to just flash it. If you need things already there, you’ll probably need to do a lot of work. Sometimes truncated data is placed in “/lost+found”, which could speed up figuring out what needs rescue when data was cut from the file system in order to keep the file system usable. Temporary files being “stuck” could be a different issue not easily traced.

To work directly on the Jetson you’ll need access via either ssh or serial console. Do you have ssh available? If not, serial console is the go to method of emergency access. See this for serial console wiring:

Alternately, you can clone the root partition, and examine, repair, or edit as needed from your host computer without needing the Jetson…and after any repair, flash again with the option to reuse an existing rootfs which was from the clone/repair. If you choose to work from your host machine without serial console or ssh, you can see some Jetson TK1 information which mostly applies also to the TX1:
…clone commands specific to the TX1:

Regarding a cloned rootfs image, if it is named “clone.img”, then on your host you could do something like this to mount it read-only:

sudo mount -o loop,ro clone.img /mnt

…which would make the image replace the content of “/mnt” with the image. You could run commands there such as file system repair:

sudo fsck.ext4 /mnt

…or simply browse “/mnt/lost+found”.

Word of warning: Clones take a lot of time, and produce a file the size of the entire partition, so expect to need about 15GB or more of free disk space.