Error building python bindings. Need Help

~$ sudo pip3 install pyds-1.1.1-py3-none-linux_aarch64.whl
[sudo] password for nikhil:
The directory ‘/home/nikhil/.cache/pip/http’ or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
The directory ‘/home/nikhil/.cache/pip’ or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo’s -H flag.
Requirement ‘pyds-1.1.1-py3-none-linux_aarch64.whl’ looks like a filename, but the file does not exist
Processing ./pyds-1.1.1-py3-none-linux_aarch64.whl
Exception:
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/pip/basecommand.py”, line 215, in main
status = self.run(options, args)
File “/usr/lib/python3/dist-packages/pip/commands/install.py”, line 342, in run
requirement_set.prepare_files(finder)
File “/usr/lib/python3/dist-packages/pip/req/req_set.py”, line 380, in prepare_files
ignore_dependencies=self.ignore_dependencies))
File “/usr/lib/python3/dist-packages/pip/req/req_set.py”, line 620, in _prepare_file
session=self.session, hashes=hashes)
File “/usr/lib/python3/dist-packages/pip/download.py”, line 809, in unpack_url
unpack_file_url(link, location, download_dir, hashes=hashes)
File “/usr/lib/python3/dist-packages/pip/download.py”, line 715, in unpack_file_url
unpack_file(from_path, location, content_type, link)
File “/usr/lib/python3/dist-packages/pip/utils/init.py”, line 617, in unpack_file
flatten=not filename.endswith(‘.whl’)
File “/usr/lib/python3/dist-packages/pip/utils/init.py”, line 500, in unzip_file
zipfp = open(filename, ‘rb’)
FileNotFoundError: [Errno 2] No such file or directory: ‘/home/nikhil/pyds-1.1.1-py3-none-linux_aarch64.whl’

@junshengy Do you suggest i reinstall deepstream sdk because of the errors above?

I get an error pyds-1.1.1-py3-none-linux_x86_64.whl is not a supported wheel on this platform.

aarch64 is for jetson, x86_64 is for dGPU. It represents different cpu architectures.

Please download the *.whl to your jetson first.

If you can not run deepstream --version-all in bash normally, please don’t rush to install python binds first.

Read this documention for initial understanding

After running the command deepstream --version-all and deepstream --version, I get bash: deepstream: command not found. But I have deepstream sdk installed, does this mean it’s not installed properly? Do I need to reinstall? @junshengy Do you recommend I reinstall DeepStream SDK?

Sorry for the wrong spell, It should be deepstream-app --version-all.

If deepstream-app --version-all gave me the same error-deepstream: command not found , do I need to reinstall DeepStream SDK? If yes, to uninstall do I just delete the DeepStream folder or are there specific commands to uninstall it?

I have DeepStream 6.0.1 installed and want to uninstall and reinstall it.

To remove DeepStream 6.0.1:

  1. Open the uninstall.sh file in /opt/nvidia/deepstream/deepstream/
  2. Do I need to Set PREV_DS_VER as 6.0 (or Set PREV_DS_VER as 6.0.1)?? @junshengy
  3. Run the following script as sudo ./uninstall.sh (Do I need to run this script inside the /opt/nvidia/deepstream/deepstream/ folder ?)

Pls clarify if I need to set PREV_DS_VER as 6.0 or as 6.0.1 and from which directory do I run the uninstall.sh script

After carrying out the 3 steps above, do I also need to manually delete the deepstream folder under /opt/nvidia folder before I reinstall Deepstream SDK again ?? @junshengy

@junshengy Kindly please revert.

Have you installed deepstream sdk successfully ?

In addition to deepstrea-app, you can run deepstream-test1-app for testing first.

Its code is in /opt/nvidia/deepstream/deepstream/sources/apps/sample_apps/deepstream-test1

Yes, I’ve reinstalled DS, I’m trying to run a sample app now.

Do I have to Install the NVIDIA display driver 470.63.01 to run sample/custom DS applications after installing DS?

$ deepstream-app --version-all
deepstream-app version 6.0.1
DeepStreamSDK 6.0.1
CUDA Driver Version: 10.2
CUDA Runtime Version: 10.2
TensorRT Version: 8.2
cuDNN Version: 8.2
libNVWarp360 Version: 2.0.1d3

Do I need to update/install anything else begin I begin creating custom applications on deepstream sdk?

To install Python bindings, I’ve come across two links that match my configurations, here’s link1 and here’s link2

Is it okay to install the python bindings from either of the 2 links? I feel using link1 is easier as it involves downloading a .whl file, can I go ahead and install the python bindings from this link?

Kindly please help me with the step by step instructions for installing python bindings from link1 for aarch64 architecture.

Aren’t you using jetson nano? jetson nano’s gpu driver is part of jetpack

Download aarch64 from link1 and run the command line pip3 install pyds-1.1.1-py3-none-linux_aarch64.whl .

Then run then deepstream_test_1.py for test

So I don’t have to carry out getting up all the base dependencies from link2 if I’m downloading the .whl file from link1 right?

Apart from this, is there anything else I need to install regarding python bindings from link1 to run sample/custom apps on DS ? The .whl file from link1 takes care of the dependencies also right?

apt install -y git python-dev python3 python3-pip python3.6-dev python3.8-dev cmake g++ build-essential \
    libglib2.0-dev libglib2.0-dev-bin python-gi-dev libtool m4 autoconf automake

The dependencies still need to be installed.

The *.whl just avoid build the pyds by yourself.
Compiling python bindings is very tedious.

After downloading the .whl file and pip3 install, what do I do next ?

Deepstream’s documentation has a detailed description

After pip3 install command, don’t I have to compile the python bindings ?

Kindly pls help me through this.