Error Building SDK Project Example

I got the following building error when I tried to run an SDK project example. Any ideas for fixing it are appreciated.

system:
Dell Precision T7400
CUDA 1.1
RedHat
Tesla C870
Latest drivers are installed

gmstrie@akoglu1:~/Desktop/ReductionCuda/NVIDIA_CUDA_SDK$ make
make[1]: Entering directory /home/gmstrie/Desktop/ReductionCuda/NVIDIA_CUDA_SDK/common' a - obj/release/bank_checker.cpp_o a - obj/release/cmd_arg_reader.cpp_o a - obj/release/cutil.cpp_o a - obj/release/stopwatch.cpp_o a - obj/release/stopwatch_linux.cpp_o a - obj/release/multithreading.cpp_o make[1]: Leaving directory /home/gmstrie/Desktop/ReductionCuda/NVIDIA_CUDA_SDK/common’
make[1]: Entering directory /home/gmstrie/Desktop/ReductionCuda/NVIDIA_CUDA_SDK/common' make[1]: Makefile_paramgl: No such file or directory make[1]: *** No rule to make target Makefile_paramgl’. Stop.
make[1]: Leaving directory `/home/gmstrie/Desktop/ReductionCuda/NVIDIA_CUDA_SDK/common’
make: *** [lib/libparamgl.so] Error 2

I checked the common directory, and it indeed has paramgl.h in it. So I’m not sure why it is throwing this error.

The problem is that Makefile_paramgl isn’t being found. Are you sure that the SDK package that you downloaded isn’t incomplete?

I downloaded just the single program parallel reduction program from this location on the website:
http://developer.download.nvidia.com/compu…Algorithms.html
It appears to be complete, it just doesn’t have all of the programs that the full SDK has.

Hello, I had the same problem over here, so here’s the solution:

Imagine you want to compile the example named transposed. Instead of issuing make in the ‘top’ directory (e.g. /home/filipem/Desktop/NVIDIA_CUDA_SDK), proceed in the following manner:

cd projects/transpose

make

Hope it solves your problem, as it solved mine.

Best Regards,

Filipe

Hello,

I don’t understand the fix given prior to my response. Can someone provide a fix? I’m having the same problem trying to install a single code example from SDK.

Thanks.

Please give more details. Which version of linux do you have and which version of gcc?Did the cudatoolkit install? If yes which version? What errrs do you get when you try to compile the examples?