Error cloning and restoring Jetson Orin

I am following the steps metioned in Flashing Support — Jetson Linux<br/>Developer Guide 34.1 documentation to clone a jetson orin.

  1. First, I tried cloning the device. While creating the image <clone>.img the image starts to get created and the size starts to increase (as expected) but when it finishes the size of the image goes to 0kb and when I try to clone the device I get Error: Return value 10 File to be written cannot be of zero size which makes sense because the size of the file is 0kb. Why is this happening?

  2. I tried the second option to backup and restore following instructions in /Linux_for_Tegra/tools/backup-restore/README_backup_restore.txt
    The command sudo ./tools/backup_restore/ -b jetson-agx-orin-devkit workd fine and creates multiple system images within Linux_for_Tegra/tools/backup_restore/images
    When I move on to the second step I get the following error:
    sudo ./tools/backup_restore/ -r jetson-agx-orin-devkit

Hi user133662,

Are you using the devkit or custom board?

What’s the command you run for generating clone image?
Please also provide the full host side log for further check.

For Orin NX, you could refer to the following thread to clone and restore for NVMe drive.
How to clone Orin NX APP partition to host PC - Jetson & Embedded Systems / Jetson Orin NX - NVIDIA Developer Forums

Dev kit

sudo ./ -r -k APP -G clone.img jetson-agx-orin-devkit mmcblk0p1

I am following the exact same instructions from Flashing Support — Jetson Linux<br/>Developer Guide 34.1 documentation

Where can I find the logs for the cloning process?
This is the output from the console:

I am using AGX Orin Developer kit.

Is backup and restore meant for the same jetson or can it be used to clone?

Are you using Orin or Orin NX?
(the current category of this topic is for Orin NX)

Yes, the log output from console is what I request for.
“is muple of 4096” issue is coming from mksparse.
Your rootfs size should be divided by 4096.

Could you help to check the size of mmcblk0p1 with the following command on your board before clone?

$ sudo blockdev --getsize64 /dev/mmcblk0p1

I modified with the changes described in the link below:

Also modified flash_t234_qspi_sdmmc.xml with the changes described below:

My files: flash_t234_qspi_sdmmc.xml (35.6 KB) (6.4 KB)

I get the same result when creating the clone. The size of the image is 0 bytes

Use the clone.img.raw to flash the target device.
sudo cp clone.img.raw bootloader/system.img
sudo ./ -r jetson-agx-orin-devkit mmcblk0p1

After modifying the files mentioned above and using clone.img.raw, I was able to succesfully clone and flash Jetson Orin AGX

Orin AGX, my bad. I made a mistake when creating the topic.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.