Error code 29 - Installing JetPack for L4T 2.1

Hi, I am installing JetPack for L4T version 2.1 on my host (Kubuntu 14.04 LTS, Intel i7, Nvidia GPU with CUDA and drivers installed). After running the installer of the “JetPack for L4T” and selecting a full installation with the host and TK1 software (also the installer is able to download all the software), I get an unknown error code 29. the log of the installation is this:

03-28 21:45:42.8 N: Install com.nvidia.nvtools.battle 2.1.15341; Install com.nvidia.nvtools.quadd 2.5.20194751; Install com.nvidia.samples.gameworks 2.11; Install com.nvidia.samples.compile_gw_tk1 2.11; Install 2.1; Install com.nvidia.cuda.host_tk1 6.5.50; Install com.nvidia.l4t.driver4os_tk1 21.4.0; Install com.nvidia.l4t.filesystem_tk1 21.4.0; Install com.nvidia.l4t.flash_tk1 21.4.0; Install com.nvidia.cuda.l4t_tk1 6.5.50; Install com.nvidia.cuda.compile_cuda_tk1 6.5.50; Install com.nvidia.middleware.cudnn_tk1 v2; Install org.opencv.middleware.ocv_l4t_tk1; Install com.nvidia.middleware.visionworks_target_tk1 1.2.3; Install com.nvidia.middleware.visionworks_target_sfm_tk1 0.82.2; Install com.nvidia.middleware.visionworks_target_tracking_tk1 0.80.3; Install com.nvidia.nvtools.perfkit_tk1 4.5.1;
03-28 21:45:46.3 E: Installing Tegra Graphics Debugger 2.1.15341 failed.

The popup message is this one:

Return Code: 29

Installing Tegra Graphics Debugger 2.1.15301 failed.

I have tried to disable the installation of “Tegra Graphics Debugger” but the error persist with the remainder software.

¿Any idea how to solve this?


JetPack has a limitation that spaces are not supported in the installation path, can you please check if this is the case?

Hi, the installation path is “/home/henry/nvidia/21/” so no spaces.

You have attempted to delete and reinstall JetPack on the host, correct?

I am getting the same error code.

04-07 16:22:40.0 E: fopen failed, errno = 2
04-07 16:22:57.8 N: Install com.nvidia.l4t.driver4os_tk1 21.4.0; Install com.nvidia.l4t.filesystem_tk1 21.4.0; Install com.nvidia.l4t.flash_tk1 21.4.0; 
04-07 16:30:41.5 E: Operation was aborted by an application callback
04-07 16:31:27.8 E: Operation was aborted by an application callback
04-07 16:31:28.8 E: Installing Driver for OS 21.4.0 failed.

Return Code: 29

4.2.0-35-generic #40~14.04.1-Ubuntu SMP Fri Mar 18 16:37:35 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Ubuntu 14.04.4 LTS

I have tried deleting the installer folder and trying again. I have deleted the and downloaded it again. I have plenty of hard drive space. The path has no spaces. I have tried installing JetPack-L4T-2.0 and get the same rrror.

Is there anywhere I can just download the images without using the installer and flash them myself?

I’m unsure of JetPack as I use Fedora, but I’m wondering if that message is for driver install on the host? If so, what video card do you use on the host?

The JetPack is just a bundle of software, the individual installer is simpler in many ways (finding and downloading all the packages you want is a pain without JetPack, but can be done). The URL for driver package and sample rootfs are the minimum requirements. For a Jetson TK1, the most recent is R21.4:

Basically you unpack the driver, go into the Linux_for_tegra/rootfs, unpack the sample rootfs, and then cd back to Linux_for_tegra, followed by running sudo ./ At this point you are ready to flash if your Jetson is in recovery mode with USB micro connector connected. The most common flash command is:

sudo ./ -S 14580MiB jetson-tk1 mmcblk0p1

Flash creates a loopback copy of the file system, along with a sparse (compressed) version, so before you run the actual flash expect that about 30GB of disk is a good amount to have spare prior to flash starting.

I just noted that you are using Kubuntu instead of Ubuntu. JetPack only officially supports Ubuntu.

When you met this error when installing Tegra Graphics Debugger, can you please check further with the following steps:

  1. cd <install_dir>/_installer
  2. grep “./InstallUtil install com.nvidia.nvtools.battle” /tmp/jetpack_debug.log file
  3. Run the command found in step 2 and see what’s the error message?

That works for me, thanks!

I am also using Kubuntu

I had similar issues. Here’s a list of things I discovered. Hope I can save someone else some time.

  1. Kubuntu does not work.
  2. VirtualBox auto-growing virtual disks do not work.
  3. VirtualBox VMs USB device drivers do not work.

I had to drag an old laptop out of the garage, install Ubuntu 14.04 and then everything worked.

Do not veer from the defaults or you’ll waste hours, just like I did.