Error Deploying my own defined operator

We have tried deploying our own model as a pipeline with Clara Deploy SDK, but runs into an error.

my config_inference.json in the URL below
https://drive.google.com/file/d/1GtRl_SmXma8mHmwLOSpRS2oboA_76erq/view?usp=sharing

Hi chananvich,

What version of the Clara Train SDK are you using? Based on the error messages, it looks like you are using app_base_inference v1. This is compatible with Clara Train v1 and has been deprecated.

There is a new v2 version of the base inference app that is compatible with more recent versions of the Clara Train SDK. You can find the container and docs here:
https://ngc.nvidia.com/catalog/containers/nvidia:clara:app_base_inference_v2

Thanks,
Kris

Thanks for your suggestion we have solved the error above by changing to app_base_inference_v2.
However, we have run into a different error RuntimeError: No active exception to reraise
before the error message there are multiple lines of INFO:app.App:Trying to check TRTIS server health
The error message occurs when we use the bash script docker_run.sh
The image of this error is embeded in this message, together with some config files and curl output of trtis docker.
Please tell us if further information is required.



curl_output.txt (1.2 KB)

Hi chananvich,

The curl output looks OK, but there are some errors in the docker_run.sh output. In the first screen capture the script fails to find envsetup.sh. And after the error messages in the second screen capture, it looks like a syntax error in run_covid_docker.sh.

Can you share the docker_run.sh and run_covid_docker.sh scripts? Will you also check the path for the envsetup.sh script?

Thanks,
Kris

run_covid_docker.sh and docker_run.sh is embeded below. we can’t find envsetup.sh in any place, where can we find the file and what does it do?

docker_run.sh (2.5 KB)

run_covid_docker.sh is a legacy code from v1 and it’s not longer used
run_covid_docker.sh (2.7 KB)

We solved the previous problem by renaming graphdef file.

But, we have a new problem. When I run docker_run.sh

below is the zipped model repository containing .pbtxt file and .trt.pb file that is renamed to model.graphdef
Model Repository (G-Drive)