ERROR : Flash Jetson TX2 : lost connection

When trying to flash the JetsonTX2 with Jetpack 4.2 it gave me this error after it was at 14.4% done flashing

15:58:08 ERROR : Flash Jetson TX2 : lost connection

And the automatic setup for flashing the Jetson doesn’t read the Jetson I had to manually put it in recovery mode for it to start flashing. It is a brand new TX2.

First, is the host a VM? If so, then this would be a cause. However, there have been a number of people who have seen the same thing, and the TX2 probably works well (the SDK Manager is new, so don’t panic).

First, see if Python is installed (I think it is Python 2.7 and SDK manager might not mention if it is missing):

sudo apt install -y python

There is a very useful post basically on this topic here:

Note that both the TX2 and the Xavier use the new SDK Manager, so that post would also apply to the TX2 (though you might need to substitute “TX2” for “Xavier” mostly it is a verbatim copy of instructions for flashing the two targets).

Hi - I have exact same problem - lost connection at 14.4%. There’s a number of “errors” listed in the command window, including a Python one but several others too.
Are you saying python should be installed on host or target?


Thank you, @linuxdev. This works for me! I am using a Ubuntu 18.4 virtual machine on my MacBook Pro.

For future people, after sudo apt install -y python, I still saw the lost connection error, but it this time it didn’t stop flashing.

After I flashed Jetson OS, SDK Manager will pause and pop up the log in dialog. At this moment, Jetson OS has been flashed. You need connect your TX2 with monitor and keyboard to set up your TX2 with new username and password.

Once above step done, you can continue flash Jetson SDK components to your TX2.

thank you @linuxdev, this also worked for me! Thx

I am facing the same error . In automatic mode to flash the target it isn’t able to detect the Jetson tx2, but in manual mode the jetson tx2 is visible( checked via lsusb command in terminal).Hence i try to flash every time in manual mode.
I have python 2.7.12 installed in my host-> ubuntu 16.04(not via Virtualbox). I don’t see an error in python from the logs but error in executing ./ command.
This is my error log:

17:30:15 ERROR : Flash Jetson TX2 : Run commands failed at step Install: command sudo ./ jetson-tx2 mmcblk0p1 finished with error
17:30:15 INFO : Flash Jetson TX2 :
17:30:15 ERROR : Flash Jetson TX2 : command terminated with error

Error displayed:
Could not detect target hardware
Please make sure the target hardware is connected and is in recovery mode, click OK and RETRY.

In between flashing the jetson OS the error occurs.
Note: I have configured ubuntu in my jetson tx2,which is up and running.

I’m not sure what you mean by automatic mode and manual mode. If you were to flash on command line, then it would go something like this after the TX2 is visible via lsusb:

sudo ./ jetson-tx2 mmcblk0p1

If you wanted this to log, and reduce some of the progress bar spam, you might do this:

sudo ./ jetson-tx2 mmcblk0p1 2>&1 | gawk '{gsub("[0-9][0-9]+[/][0-9[0-9]+ bytes sent..",".");print}' | tee log.txt

If you hover your mouse over the quote icon in the upper right of one of your existing posts, then more icons will show up. The paper clip icon is for attaching files.

Thanks for the reply @linuxdev ,
My issue got resolved once i removed a package name tlp.
In another topic: it was mentioned. I removed and restarted my system and things worked fine.