Error Flashing an OP-TEE TOS for JP 5.0.2

Hey folks, simple question but still getting my bearings w/ developing on Jetson.

Currently I’m working on a signed Nvidia NX and I want to flash my compiled tos.img following the instructions laid out in atf_and_optee_README.txt, provided from the BSP download on the Jetson Linux 35.1 download page.

Running sudo ./flash.sh -k secure-os target_board mmcblk0p1 gives me this error:

ozy@san-00734:~/jetpack-sdks/jp5.0.x/Linux_for_Tegra$ sudo ./flash.sh -k secure-os /path/to/my/board mmcblk0p1
###############################################################################

L4T BSP Information:

R35 , REVISION: 1.0

###############################################################################

Target Board Information:

Name: target_board , Board Family: t186ref, SoC: Tegra 194,

OpMode: production, Boot Authentication: NS,

Disk encryption: disabled ,

###############################################################################
copying soft_fuses(/home/ozy/jetpack-sdks/jp5.0.x/Linux_for_Tegra/bootloader/t186ref/BCT/tegra194-mb1-soft-fuses-l4t.cfg)… done.
./tegraflash.py --chip 0x19 --applet “/home/ozy/jetpack-sdks/jp5.0.x/Linux_for_Tegra/bootloader/mb1_t194_prod.bin” --skipuid --soft_fuses tegra194-mb1-soft-fuses-l4t.cfg --bins “mb2_applet nvtboot_applet_t194.bin” --cmd “dump eeprom boardinfo cvm.bin;reboot recovery”
Welcome to Tegra Flash
version 1.0.0
Type ? or help for help and q or quit to exit
Use ! to execute system commands

[ 0.0072 ] Generating RCM messages
[ 0.0102 ] tegrahost_v2 --chip 0x19 0 --magicid MB1B --appendsigheader /home/ozy/jetpack-sdks/jp5.0.x/Linux_for_Tegra/bootloader/mb1_t194_prod.bin zerosbk
[ 0.0124 ] Header already present for /home/ozy/jetpack-sdks/jp5.0.x/Linux_for_Tegra/bootloader/mb1_t194_prod.bin
Error: Return value -9
Command tegrahost_v2 --chip 0x19 0 --magicid MB1B --appendsigheader /home/ozy/jetpack-sdks/jp5.0.x/Linux_for_Tegra/bootloader/mb1_t194_prod.bin zerosbk
Reading board information failed.

Presumably it’s because the board isn’t correctly in recovery mode?

Bump.

hello tadas.aleksonis,

assume you’re working with Xavier NX Developer Kit.
please check JetPack release, which install to your local host.
there’ll be jetson-xavier-nx-devkit.conf, you should assign the flash command as… sudo ./flash.sh -r -k secure-os jetson-xavier-nx-devkit mmcblk0p1.
note, -r option is added to re-use system.img for saving flash process time.

Flashing issue was resolved by using a separate laptop. Not sure why that was the fix, but the issue has been resolved.

hello ozy,

note, we usually use a desktop for flashing a target.

since there’ll be several USB connect/disconnect during image flashing process. it sometimes switch to other USB port could workaround this issue on laptop. also, you should ensure you used a good quality USB wire.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.