Error flashing Orin Nano devkit 8 GB w/ 500 GB NVME gen 3 SSD


sdkm-2024-04-07-19-06-24.log (317.8 KB)

Ubuntu 20 host system. Trying to install Jetpak 6.0 DP on orin nano

I had been able to successfully flash the orin nano in the past.
Something in ubuntu broke so i decided to reflash it.
First tried with the updated SDK manager 2.1, had the same error, and then reverted to the Sdk manager 2.0.1 but getting the same error (see screenshot and log file).

I dont see how is this reply related to my issue.
Can you please guide me a bit more ?

A known issue for ubuntu 20.04 host is the USB autosuspend function is enabled on it by default. This leads to Jetson recovery mode gets suspended before flash. To bypass this error, need to:

  1. Disable autosuspend on host PC with below command:

sudo -s
echo -1 > /sys/module/usbcore/parameters/autosuspend

  1. Plug out the USB cable, put jetson back into recovery mode again and plug the usb cable back.

If USB timeout is still there after above commands, please file a topic to forum and let moderator help check.

Okay I see, and is this a known issue in ubuntu 22 as well ?

YES.
Make sure USB autosuspend is disabled and manually put the device in force recovery mode again.

Disabling the autosuspend worked !
Thank you very much for the prompt help :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.