Error flashing TX2

Hi, I’m unable to flash TX2s using the Tegra flash script. I am able to see the TX2 device when I run lsusb but always get error 3. I should mention that I’m running this from within a Docker container. Here’s the console output below. Any advice is appreciated!
Thanks,
Doug Burrell

Bus 002 Device 024: ID 0955:7c18 NVidia Corp.
Bus 002 Device 022: ID 2109:2812 VIA Labs, Inc. VL812 Hub
Bus 002 Device 021: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Bus 002 Device 020: ID 2109:2812 VIA Labs, Inc. VL812 Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
root@l157:/usr/src/jetpack/64_TX2/Linux_for_Tegra_tx2# sudo ./flash.sh smartsense-1 mmcblk0p1
./tegraflash.py --chip 0x18 --applet “/usr/src/jetpack/64_TX2/Linux_for_Tegra_tx2/bootloader/mb1_recovery_prod.bin” --cmd “dump eeprom boardinfo cvm.bin” --skipuid
Welcome to Tegra Flash
version 1.0.0
Type ? or help for help and q or quit to exit
Use ! to execute system commands

[ 0.0015 ] Generating RCM messages
[ 0.0023 ] tegrarcm_v2 --listrcm rcm_list.xml --chip 0x18 --download rcm /usr/src/jetpack/64_TX2/Linux_for_Tegra_tx2/bootloader/mb1_recovery_prod.bin 0 0
[ 0.0030 ] RCM 0 is saved as rcm_0.rcm
[ 0.0034 ] RCM 1 is saved as rcm_1.rcm
[ 0.0034 ] List of rcm files are saved in rcm_list.xml
[ 0.0034 ]
[ 0.0035 ] Signing RCM messages
[ 0.0048 ] tegrasign_v2 --key None --list rcm_list.xml --pubkeyhash pub_key.key
[ 0.0058 ] Assuming zero filled SBK key
[ 0.0105 ]
[ 0.0105 ] Copying signature to RCM mesages
[ 0.0121 ] tegrarcm_v2 --chip 0x18 --updatesig rcm_list_signed.xml
[ 0.0138 ]
[ 0.0138 ] Boot Rom communication
[ 0.0147 ] tegrarcm_v2 --chip 0x18 --rcm rcm_list_signed.xml --skipuid
[ 0.0154 ] Boot Rom communication failed
[ 3.1434 ]
Error: Return value 3
Command tegrarcm_v2 --chip 0x18 --rcm rcm_list_signed.xml --skipuid
Reading board information failed.

Is this a custom board? Is the host a VM?

Yes it’s a custom board, no the host is not a VM, well, it’s in a Docker container so sort of a VM. I should also note that other developers are able to get flash TX2s on the same board so it’s not an issue with the board but something whacky on my machine.

Docker should be considered on the same line as any VM since USB has to pass through. This is always suspicious, though it could be many things with a custom board. I’d suggest you try with a native host.

I tried it on my native host also when I first installed the Jetson Jetpack SDK but same issue.

If it fails in the same way with a native host PC, then there is probably an issue such as board ID getting in the way (I’m assuming it isn’t a USB issue for native PC…for docker it probably is a USB issue…it may be that you have two issues resulting in the same error, but it seems unlikely).

Someone else will need to comment on how flash needs to change with a custom board (I am assuming here that docker is not the cause of failure due to the same error existing from a native Linux PC flash).

The problem is that other users here are able to flash the exact same board just fine, so I don’t believe it’s a board id issue. What sort of configuration on my laptop could be getting in the way of the flash script communicating with devices over USB?

Docker would get in the way, but since you are getting the same issue without Docker or a VM, there is a slight chance it is the USB cable…on rare occasions it does solve such issues.

In terms of other users flashing that board successfully you’d have to find out if they first edited the board ID.

I’ve tried the USB cable on other machines and it works fine.