Error Flashing Xavier Industrial

Hi, I am using the Xavier AGX dev kit carrier board to flash an OS to a Xavier Industrial module. I can connect via USB.
However, when I attempt to actually flash the OS, it gets to 1% and errors out.
When this happens, I can see the USB connection break and then come back. I don’t know if it is the cause of the error, or a symptom.
I attached a photo of the error summary from SDK.
Thank you!

Are you on VM or native Ubuntu OS PC?
Which Ubuntu OS version?
Which JetPack you’re installing?

Hi adam.wannemacher,

Check logs, the SDK Manager can’t detect your Xavier-Industrial in recovery mode.
Please check below two things:

  1. Select correct target hardware from SDKM steps 1:
    Jetson AGX Xavier modules -> P2888-0008 for Industrial
  2. Put your Jetson device into recovery mode by manually and using lsusb command to check on your host Ubuntu machine.

Native Ubuntu OS, 20.04.4 LTS
I tried both Jetpack 5.0.1 and 5.0

It seems like SDK does recognize the Xavier Industrial is in recovery mode, at least at first.
It sees it, and the host computer recognizes the USB connection.
But, the USB connection breaks and comes back when flash process begins, I captured a photo of it happening:

Could you try with other USB cable?

I changed to Jetpack 4.6.2 (I got another laptop with Ubuntu 18.04) and this solved the issue. I was able to flash the OS, and it boots as expected

1 Like