Error for driver on booting to linux

Shalom from Israel! I have a Windows laptop that I recently set up to dual boot to both Windows 10 and Linux Fedora. The laptop has a GeForce GTS 1650 which works fine in Windows and until recently also worked fine in Fedora. Now when OI boot to Fedora, I get an error message concerning the Nvidia Kernal and that it’s reverting to Nouveau. I try to download drivers but when I do, they come with the suffix .run and when I click on them, they always open a text editor instead. I need some help to figure out how to fix this. Thanks in advance.

Please don’t use the .run installer. How did you previously install the driver?
Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

I installed it when I installed Fedora, I guess. But I don’t know how to do what you suggested. How do I run the report as root?

Simply run
and attach the mentioned file.

When I try to run that, I’m asked for my password but nothing happens when I type it and press enter

It should have created a file
Please attach that.

nvidia-bug-report.log.gz (56.7 KB)

You have secure boot enabled, IDK if fedora/rpmfusion provides signed nvidia modules. Please try disabling secure boot in bios.

That fixed the problem. Thanks so much for your help!