ERROR from sink_sub_bin_udpsink2: Could not get/set settings from/on resource

When I run yolov3 on Xavier, the input signal is the Hikvision camera RTSP video stream, and the following error occurs when performing object detection and outputting the RTSP video stream:

DeepStream: Launched RTSP Streaming at rtsp://localhost:8554/ds-test

Warn: ‘threshold’ parameter has been deprecated. Use ‘pre-cluster-threshold’ instead.
** ERROR: main:653: Failed to set pipeline to PAUSED
Quitting
ERROR from sink_sub_bin_udpsink2: Could not get/set settings from/on resource.
Debug info: gstmultiudpsink.c(1278): gst_multiudpsink_configure_client (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin2/GstUDPSink:sink_sub_bin_udpsink2:
Could not join multicast group: Error joining multicast group: No such device
ERROR from sink_sub_bin_udpsink2: GStreamer error: state change failed and some element failed to post a proper error message with the reason for the failure.
Debug info: gstbasesink.c(5265): gst_base_sink_change_state (): /GstPipeline:pipeline/GstBin:processing_bin_0/GstBin:sink_bin/GstBin:sink_sub_bin2/GstUDPSink:sink_sub_bin_udpsink2:
Failed to start
App run failed

My config file is as follows:

[application]
enable-perf-measurement=1
perf-measurement-interval-sec=5
#gie-kitti-output-dir=streamscl

[tiled-display]
enable=1
rows=1
columns=1
width=1280
height=720
gpu-id=0
#(0): nvbuf-mem-default - Default memory allocated, specific to particular platform
#(1): nvbuf-mem-cuda-pinned - Allocate Pinned/Host cuda memory, applicable for Tesla
#(2): nvbuf-mem-cuda-device - Allocate Device cuda memory, applicable for Tesla
#(3): nvbuf-mem-cuda-unified - Allocate Unified cuda memory, applicable for Tesla
#(4): nvbuf-mem-surface-array - Allocate Surface Array memory, applicable for Jetson
nvbuf-memory-type=0

[source0]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI
type=2
#uri=file://…/…/samples/streams/sample_1080p_h264.mp4
#uri=rtsp://admin:infiled8899@10.10.150.119:554/h264/ch2/main/av_stream
#uri=file://10-12.mp4
uri=rtsp://admin:sutpc654321@10.2.1.13:554/h264/ch1/main/av_stream
#uri=rtsp://admin:sutpc654321@172.1.49.13:554/h264/ch1/main/av_stream
num-sources=1
gpu-id=0

(0): memtype_device - Memory type Device

(1): memtype_pinned - Memory type Host Pinned

(2): memtype_unified - Memory type Unified

#latency=600
camera-fps-n=25
cudadec-memtype=0

[sink0]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File
type=1
sync=0
source-id=0
gpu-id=0
nvbuf-memory-type=0

[sink2]
enable=1
#Type - 1=FakeSink 2=EglSink 3=File 4=RTSPStreaming
type=4
#1=h264 2=h265
codec=1
sync=0
bitrate=4000000

set below properties in case of RTSPStreaming

rtsp-port=8554
udp-port=5402

[osd]
enable=1
gpu-id=0
border-width=1
text-size=15
text-color=1;1;1;1;
text-bg-color=0.3;0.3;0.3;1
font=Serif
show-clock=0
clock-x-offset=800
clock-y-offset=820
clock-text-size=12
clock-color=1;0;0;0
nvbuf-memory-type=0

[streammux]
gpu-id=0
##Boolean property to inform muxer that sources are live
live-source=0
batch-size=1
##time out in usec, to wait after the first buffer is available
##to push the batch even if the complete batch is not formed
batched-push-timeout=40000

Set muxer output width and height

width=1920
#2560
height=1080
#7
##Enable to maintain aspect ratio wrt source, and allow black borders, works
##along with width, height properties
enable-padding=0
nvbuf-memory-type=0

config-file property is mandatory for any gie section.

Other properties are optional and if set will override the properties set in

the infer config file.

[primary-gie]
enable=1
gpu-id=0
model-engine-file=model_b1_gpu0_int8.engine
labelfile-path=labels.txt
batch-size=1
#Required by the app for OSD, not a plugin property
bbox-border-color0=1;0;0;1
bbox-border-color1=0;1;1;1
bbox-border-color2=0;0;1;1
bbox-border-color3=0;1;0;1
interval=2
gie-unique-id=1
nvbuf-memory-type=0
config-file=config_infer_primary_yoloV3.txt

[tracker]
enable=1
tracker-width=640
tracker-height=384
ll-lib-file=/opt/nvidia/deepstream/deepstream-5.0/lib/libnvds_mot_klt.so

[tests]
file-loop=0

Hi,
Please run the pipeline to check if your URI is valid:

gst-launch-1.0 uridecodebin uri='rtsp://admin:sutpc654321@10.2.1.13:554/h264/ch1/main/av_stream' ! nvoverlaysink

Hi,DaneLLL
I tried this instruction and my URI is valid.
thanks

Hi,
You may set source to type=4 and give it a try.