Error getting the samples of ZED into Jetson tk1

Hey,

I am installing the ZED on my Jetson TK1 and while adding the samples I got these lines
"

Install samples (recommended) (Y/N)? 
Installation path: /usr/local/zed/sample/
update-rc.d: warning: /etc/init.d/Perfmode.sh missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>
 Adding system startup for /etc/init.d/Perfmode.sh ...
   /etc/rc0.d/K80Perfmode.sh -> ../init.d/Perfmode.sh
   /etc/rc1.d/K80Perfmode.sh -> ../init.d/Perfmode.sh
   /etc/rc6.d/K80Perfmode.sh -> ../init.d/Perfmode.sh
   /etc/rc2.d/S80Perfmode.sh -> ../init.d/Perfmode.sh
   /etc/rc3.d/S80Perfmode.sh -> ../init.d/Perfmode.sh
   /etc/rc4.d/S80Perfmode.sh -> ../init.d/Perfmode.sh
   /etc/rc5.d/S80Perfmode.sh -> ../init.d/Perfmode.sh
ZED SDK is finished now !

and while trying to view the depth viewer a message says “Error detected: ZED_SETTING_FILE_NOT_AVAILABLE” appears.

what might be the problem?

Hi HAMDA_ALA,

Have the ZED SDK for TK1 been installed well?
You may need to check this issue from https://www.stereolabs.com/developers/

Besides, another forum topic was discussing the ZED on TX1, but installation should be the same, just for your reference:
https://devtalk.nvidia.com/default/topic/900926/how-to-install-the-zed-ros-driver-on-the-jtx1/

Thanks

I read the topic many times but i couldn’t understand what’s going on there. is it necessarily to download ROS in order to view the depth map?
and what about the internet connection problem? what could be the solution?

regards.

Hi HAMDA_ALA,

By referring that thread, you need to do the following to meet your original requirement:

  1. Install git
sudo apt-get install git
  1. Install ZED SDK for the JTX1 and make a link in the home directory
wget 'https://www.stereolabs.com/download_327af3/ZED_SDK_Linux_JTX1_v0.9.2_alpha.run'
chmod +x ZED_SDK_Linux_JTX1_v0.9.2_alpha.run
./ZED_SDK_Linux_JTX1_v0.9.2_alpha.run
ln -s /usr/local/zed/ ~/zed

Above example is for TX1, you need to download the one for TK1.

  1. The OpenGL Extension Wrangler Library was missing, install it to run the ZED explorer and depth viewer
sudo apt-get instal libglew-dev

For the other issue, which might not be related to your current purpose.
Thanks

I did the procedure several time but Unfortunately I am facing the same problem!
I need to display the depth map but nothing is appearing and It keep saying that I need to connect the ZED to internet.
what could be a solution for viewing the Depth Map?

Regards.

Hi HAMDA_ALA,

Sorry for not able to help you on resolving this issue, you may try to contact with ZED support directly.

Thanks