ERROR:gstqueue.c:1143:gst_queue_leak_downstream: assertion failed: (leak != NULL)

Please provide complete information as applicable to your setup.

**• Hardware Platform (Jetson / GPU) GPU
**• DeepStream Version: 6.0
• JetPack Version (valid for Jetson only)
**• TensorRT Version: 8001
**• NVIDIA GPU Driver Version (valid for GPU only): 11.7
**• Issue Type( questions, new requirements, bugs): bugs
**• How to reproduce the issue ?
i run with : ./deepstream-app -c config_file
[application]
enable-perf-measurement=1
perf-measurement-interval-sec=5

[sink0]
enable=1
type=1
sync=0
source-id=0
gpu-id=0
nvbuf-memory-type=0

[streammux]
gpu-id=0
live-source=1
batch-size=8
batched-push-timeout=40000
width=1920
height=1080
enable-padding=0
nvbuf-memory-type=0
attach-sys-ts-as-ntp=1

[primary-gie]
enable=1
gpu-id=0
batch-size=8
bbox-border-color0=1;0;0;1
bbox-border-color1=0;1;1;1
bbox-border-color2=0;0;1;1
bbox-border-color3=0;1;0;1
bbox-border-color4=1;1;0;1
interval=0
gie-unique-id=1
nvbuf-memory-type=0
config-file=config_infer_primary_detect.txt

[secondary-gie0]
enable=1
gpu-id=0
gie-unique-id=2
batch-size=8
nvbuf-memory-type=0
operate-on-gie-id=1
operate-on-class-ids=1
config-file=config_infer_traffic_accident_classify.txt

[tracker]
enable=1
tracker-width=640
tracker-height=384
ll-config-file=config_tracker_NvDCF_perf.yml
ll-lib-file=/opt/nvidia/deepstream/deepstream/lib/libnvds_nvmultiobjecttracker.so
enable-batch-process=1
enable-past-frame=0
display-tracking-id=1

[source0]
camera-id=588
select-rtp-protocol=4
uri=rtsp://xxxx
enable=1
type=4
gpu-id=0
cudadec-memtype=0
num-sources=15
rtsp-reconnect-interval-sec=5
rtsp-reconnect-attempts=-1
drop-frame-interval=5
smart-record=1
smart-rec-cache=25
smart-rec-duration=10
smart-rec-start-time=10
smart-rec-container=0
smart-rec-file-prefix=traffic_accident
smart-rec-dir-path=/data

[nvds-analytics]
enable=1
config-file=config_nvdsanalytics.txt

and i received this error:
ERROR:gstqueue.c:1143:gst_queue_leak_downstream: assertion failed: (leak != NULL)
Bail out! ERROR:gstqueue.c:1143:gst_queue_leak_downstream: assertion failed: (leak != NULL)

can anyone help me how to solve it? thanks very much

There is no update from you for a period, assuming this is not an issue any more. Hence we are closing this topic. If need further support, please open a new one. Thanks.

  1. did you modify the code? did this error happen every time? how log it will happen? could you share a whole log?
  2. could you simplify the configurations to narrow down this issue? for example, disable tracker, sgie, analytics temporarily.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.