Error: ImportError: /usr/lib/aarch64-linux-gnu/ cannot allocate memory in static TLS block (i looked through available threads already)

Hello everyone,
I recently purchased Xavier AGX to do mainly Python programming and running machine learning models (Ubuntu 18.04). So far, after installing all packages and placing TensorFlow in the separate virtual environment, everything works fine, running Jupyter Notebook, except one thing. No matter what I do this error keeps happening. I tried all suggestions online with Export lines such as: export LD_PRELOAD=/usr/lib/aarch64-linux-gnu/ and updating bashrc file. Still can’t run it. I mean, the primary reason I bought it is to run RNN models so if this thing can’t do it, I see no point in having it over my Macbook Pro that can run it without issues. I would appreciate you help to resolve this and can start doing some work with it. Thank you!

Dragan Bogatic



After you update the bashrc file, have you run the following command to reflash the device environment?

$ source ~/.bashrc

We met this issue before, and it can be solved by updating the LD_PRELOAD parameter:

$ export LD_PRELOAD=/usr/lib/aarch64-linux-gnu/


1 Like


Actually, I believe I did. But, I will do it again to make sure.

What I found worked for me was using a docker file from nvidia website. Running tensorflow with docker image solved the problem for me and I did not receive the error message when I ran the same cell. Thank you for your help!

Dragan Bogatic

1 Like

Good to know this.
Also thanks for the feedback.

1 Like

Just an update, I added again

export LD_PRELOAD=/usr/lib/aarch64-linux-gnu/


source ~/.bashrc

It works fine now…no issues running LSTM and MinMaxScaler.

Thank you for your help!