Error in Compile/link gst-nvinfer plugin C++

Please provide complete information as applicable to your setup.

**• Ubuntu 22 wsl/GTX 1650 Ti
**• DeepStream Version :6.3
**• TensorRT Version: 8.5.3.1
**• NVIDIA GPU Driver Version (valid for GPU only) : v528.79

Error in Compile/link gst-nvinfer plugin C++ [$sudo make clean install CUDA_VER=12.1 ENABLE_WSL2=1]

ubuntu@DEV-MSaeed:~$ cd /opt/nvidia/deepstream/deepstream-6.3/sources/gst-plugins/gst-nvinfer ubuntu@DEV-MSaeed:/opt/nvidia/deepstream/deepstream-6.3/sources/gst-plugins/gst-nvinfer$ sudo make clean install CUDA_VER=12.1 ENABLE_WSL2=1 [sudo] password for ubuntu: rm -rf gstnvinfer.o gstnvinfer_allocator.o gstnvinfer_property_parser.o gstnvinfer_meta_utils.o gstnvinfer_impl.o gstnvinfer_yaml_parser.o libnvdsgst_infer.so g++ -c -o gstnvinfer.o -fPIC -std=c++11 -DDS_VERSION="6.3.0" -I /usr/local/cuda-12.1/include -I …/…/includes -I …/gst-nvdspreprocess/include -I …/…/libs/nvdsinfer -DNDEBUG -w -DENABLE_WSL2 -pthread -I/usr/include/gstreamer-1.0 -I/usr/include/orc-0.4 -I/usr/include/gstreamer-1.0 -I/usr/include/x86_64-linux-gnu -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include gstnvinfer.cpp In file included from /usr/include/glib-2.0/glib/gthread.h:32, from /usr/include/glib-2.0/glib/gasyncqueue.h:32, from /usr/include/glib-2.0/glib.h:32, from /usr/include/gstreamer-1.0/gst/gst.h:27, from …/…/includes/gst-nvevent.h:36, from gstnvinfer.cpp:25: gstnvinfer.cpp: In function ‘GType gst_nvinfer_process_mode_get_type()’: /usr/include/glib-2.0/glib/gatomic.h:113:19: error: argument 2 of ‘__atomic_load’ must not be a pointer to a ‘volatile’ type 113 | __atomic_load (gapg_temp_atomic, &gapg_temp_newval, __ATOMIC_SEQ_CST); \ | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /usr/include/glib-2.0/glib/gthread.h:260:7: note: in expansion of macro ‘g_atomic_pointer_get’ 260 | (!g_atomic_pointer_get (location) && \ | ^~~~~~~~~~~~~~~~~~~~ gstnvinfer.cpp:157:7: note: in expansion of macro ‘g_once_init_enter’ 157 | if (g_once_init_enter (&process_mode_type)) { | ^~~~~~~~~~~~~~~~~ make: *** [Makefile:66: gstnvinfer.o] Error 1

There is no update from you for a period, assuming this is not an issue anymore.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

WSL is not supported, you can refer to the dependencies here: Quickstart Guide — DeepStream 6.3 Release documentation (nvidia.com)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.