Error in compiling after switching to CUDA 2.0 parse error before "__cuda_clock"

Here’s what happens when I try to compile an SDK project under CUDA 2.0

------ Build started: Project: fluidsGL, Configuration: Debug Win32 ------

Performing Custom Build Step



D:\CUDA\include\common_functions.h:70: error: parse error before "__cuda_clock"

Build log was saved at "file://d:\CUDA\NVIDIA CUDA SDK\projects\fluidsGL\Debug\BuildLog.htm"

fluidsGL - 1 error(s), 0 warning(s)

Line 70 in common_functions.h is

__device_func__(clock_t __cuda_clock(void))

Any idea what may be causing this?

I have a GF 8800GTS 512MB and 177.92 drivers.

Windows XP Pro 32bit

Any ideas? I’ve reinstalled the SDK into a different directory and it didn’t help. This happens with all projects AFAIK. I’m considering going back to 1.1

The binaries work fine, I just can’t compile anything. Are those drivers compatible with CUDA 2.0?

Obvious things first–are you using VS2005 SP1?


And you have installed the new toolkit, right?

Yep, the new toolkit and SDK. I’ve also tried reinstalling both.

All I can suggest is uninstalling both the toolkit and SDK, killing the directories completely, and then reinstalling. I’ve not seen anything like this, either on XP64 or XP32 upgrading directly from 2.0b2. Sorry…

Didn’t work :(
I’ll try it on my second OS (XP 64bit)

It works on my second OS. I suspect there are some remains of CUDA 1.1 left (in the registry?) on XP32.

I have:

  1. uninstalled both the 1.1 toolkit and SDK
  2. searched for remains in the registry, deleted one entry
  3. rebooted
  4. installed the 2.0 toolkit and sdk
  5. rebooted
  6. tried to compile something from the sdk - fail

Attempts to compile in emu debug mode fail as well. Build log in attachment.
BuildLog.htm (26.7 KB)

The problem was fixed by reinstalling VS.