Error in Installing Amber22

Hello all,
Ubuntu:22.04
CUDA version:12.3
While installing amber22, we are getting the error
Command: sudo make install

nvcc fatal : Unsupported gpu architecture ‘compute_35’
CMake Error at pbsa.cuda_generated_mlses_predict.cu.o.RELEASE.cmake:218 (message):
Error generating
/home/nabanita/softwares/amber22_src/build/AmberTools/src/pbsa/CMakeFiles/pbsa.cuda.dir//./pbsa.cuda_generated_mlses_predict.cu.o

make[2]: *** [AmberTools/src/pbsa/CMakeFiles/pbsa.cuda.dir/build.make:77: AmberTools/src/pbsa/CMakeFiles/pbsa.cuda.dir/pbsa.cuda_generated_mlses_predict.cu.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:5071: AmberTools/src/pbsa/CMakeFiles/pbsa.cuda.dir/all] Error 2
make: *** [Makefile:156: all] Error 2

Thanks in advance

cc 3.5 is for old Kepler based gpus which are not supported anymore. Please change your makefile to only build cuda cores for the cc you need.