Error in using display port of NVIDIA A40

We recently bought HP Proliant DL385 v2 server with NVIDIA A40 Graphic Card installed.
We are using Ubuntu 18.04, but we are not able to use DisplayPort of A40 Graphics card.

Solutions tried & insights :

  1. Tried different versions of Nvidia drivers.
  2. Changed the mode of graphic card to 256 MB Display Mode with Display Mode Selector Tool.
  3. Default graphics of Ubuntu in “about section” is llvmpipe and is not changing to Nvidia’s, despite using Nvidia proprietary driver from Additional Drivers settings.
  4. PRIME Settings or Profiles not showing in nvidia-settings.

Would be glad to provide more info as needed.

Please run nvidia-bug-report.sh as root and attach the resulting file here.
Also show the output of dkms status.

dkms_status_output
nvidia-bug-report.log.gz (852.3 KB)
Please find attached the outputs of the above mentioned commands as required by you.

You are running your Matrox card as the primary. Their driver does not support display offloading.

Please connect the monitor to an output on the nvidia graphics card, then create /etc/X11/xorg.conf with contents:

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:71:0:0"
    Option         "AllowEmptyInitialConfiguration"
EndSection

You could also just disable the Matrox card in bios.

1 Like