Error installation on CentOS64

Hi,

I installed the PGI Fortran Workstation on CentOS 64, and encountered the following error.


Unknown glibc version (2.12); treating like 2.4
ERROR: directory : /usr/lib/gcc/x86_64-redhat-linux/4.4.6: not found;
successful use of compilers requires existence of gcc libraries

Making symbolic links in /opt/pgi/linux86-64/9.0

Could you tell me what’s the problem and how to solve it?
Thanks!

CentOS 6.2 X64

It seems that makelocalrc cannot recognize glibc2.12.
How to modify the makelocalrc file?

Hi Andy2012,

PGI Release 9.0 is several years old so is not supported on CentOS 6.2. For a list of supported operating systems please see: https://www.pgroup.com/support/install.htm#linux_info

In some cases, older releases can be modified so they will successfully install on newer OS. However, this is not guaranteed. Please contact PGI Customer Support (trs@pgroup.com) for more information and include your product information number (PIN).

Best Regards,
Mat

Hi Mat,

Thanks, I should guarantee my product. So I will consider to use the latest version.