Error Message Igored Video card

WARNING: The NVIDIA GeForce4 MX 440 with AGP8X GPU installed in this
system is supported through the NVIDIA 96.43.xx legacy Linux
graphics drivers. Please visit
http://www.nvidia.com/object/unix.html for more information.
The 180.22 NVIDIA Linux graphics driver will ignore this GPU.

Thjis is the message that I got when I tried to install the package:

NIVIDIA-Linux-x86-180.22.-pkg1.run.

What does it mean?

When I installed the suggested alternative NVIDIA 96.43.xx for Linux legacy drivers there were no problems in the installation, but the new software could not detect my card and I tried to configure it myself. That was not success - it defaults to a very crude 800 x 640 screen. It is terrible.

My graphics card is :

NVIDIA GeForce4 MX 440 with AGP8X GPU and my NVIDIA GeForce4 MX 440 with AGP8X GPU

screen is:

model E207WFPc a Dell monitor.

Whatever i have tried has not worked. I take it this can also be installed by Synaptic. But how?

Any help appreciated.

newport-j