Error: No events written to file

Hi,

I’m having issues running the Tools Extensions for profiling in my multi threaded C++ project. I’m trying to collect information using the nvtxRangePushEx() and nvtxRangePop() functions but they both return -2. It is working fine in two of my similar projects but not this one, and it might be something wrong somewhere on my end but I can’t figure out what it might be from current output of Nsight so I need some help with that. Here is what I have tested so far with no success:

  • The nvToolsExt64_1.dll seems to load fine when starting application and it doesn't unload before quitting program, so this seems fine
  • All paths to include folders and .lib files for Nsight seem to be properly located when generating with cmake
  • Tried reinstalling nsight for visual studio
  • Tried running both the Nsight monitor and the visual studio environment in Administrator mode
  • Running different builds (release, debug etc.)
  • Updating to latest drivers
  • I have also produced troubleshoot logs as instructed at https://docs.nvidia.com/gameworks/content/developertools/desktop/nsight/troubleshooting.htm
    How can I attach them in a post here for you to see?

    Best regards,
    Oscar

    Hi again,

    Is someone at Nvidia looking at this? The issue is still there.

    Best regards,
    Oscar

    The -2 comes from NVTX_NO_PUSH_POP_TRACKING which is defined in nvToolsExt.h. It is returned from nvtxRangePushEx whenever the tool (NsightVSE in this case) does not attach.

    We decide what DLLs to intercept based on their names

    • Are all the DLL’s named properly (no renaming)?
      For example, if nvToolsExt64_1.dll was renamed this would cause the problem.

    Once the app is running under NsightVSE , can you pause it and check (either with VS debugger or with ProcessExplorer) if Nvda.ToolsExt.Injection.dll is loaded?
    If not, that means our process injection isn’t working right.
    Not loading this DLL would cause this exact problem

    Please attach your logs
    See https://devtalk.nvidia.com/default/topic/1043347/attaching-files-to-forum-topics-posts/

    Interesting. None of the Nsight .dll’s have been renamed, and the nvToolsExt64_1.dll seems to load fine when launching the application. I’m not able to reproduce the exact behavior that I had before right now, but here are the logs I took from when the issue occured.
    NsightMonitor.log (24.9 KB)
    NsightVisp.log (484 KB)