Error occur while JetPack upgrade

I install the JetPack to TX2 in Jan. 2020. (I don’t remember the exact JetPack version)
And install PyTorch 1.3.0.
Now, I want to upgrade the PyTorch 1.3.0 to 1.6.0.
After upgrading the torch, then import torch occurs below error.

OSError: libcurand.so.10: cannot open shared object file: No such file or directory

Google says that upgrade the Cuda. So I try to upgrade JetPack.

An error occurred while following “https://docs.nvidia.com/jetson/jetpack/install-jetpack/index.html#upgrade-jetpack”'s upgrade process.

following the first procedure, Upgrade L4T by referring to the OTA section of the (https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide%2Fquick_start.html%23wwpID0EXHA).

I follow the below procedure.

  1. Change the repository name and download URL in the deb commands.

The original commands are:

deb https://repo.download.nvidia.com/jetson/common r32 main

deb https://repo.download.nvidia.com/jetson/ r32 main

Where is identifies the platform’s processor:

•t186 for Jetson TX2 series

•t194 for Jetson AGX Xavier series or Jetson Xavier NX

•t210 for Jetson Nano or Jetson TX1

Change the repository name from r32 to r32.4, and to the appropriate processor name for your platform. If your platform is Jetson Xavier NX, for example:

deb https://repo.download.nvidia.com/jetson/common r32.4 main

deb https://repo.download.nvidia.com/jetson/t194 r32.4 main

3.Save and close the source configuration file.

4.Enter the commands:

$ sudo apt update

$ sudo apt dist-upgrade

but, sudo apt update returns the below error.

Get:1 file:/var/cuda-repo-10-0-local-10.0.326 InRelease
Ign:1 file:/var/cuda-repo-10-0-local-10.0.326 InRelease
Get:2 file:/var/visionworks-repo InRelease
Ign:2 file:/var/visionworks-repo InRelease
Get:3 file:/var/visionworks-sfm-repo InRelease
Ign:3 file:/var/visionworks-sfm-repo InRelease
Get:4 file:/var/visionworks-tracking-repo InRelease
Ign:4 file:/var/visionworks-tracking-repo InRelease
Get:5 file:/var/cuda-repo-10-0-local-10.0.326 Release [574 B]
Get:6 file:/var/visionworks-repo Release [1,999 B]
Get:7 file:/var/visionworks-sfm-repo Release [2,003 B]
Get:5 file:/var/cuda-repo-10-0-local-10.0.326 Release [574 B]
Get:8 file:/var/visionworks-tracking-repo Release [2,008 B]
Get:6 file:/var/visionworks-repo Release [1,999 B]
Get:7 file:/var/visionworks-sfm-repo Release [2,003 B]
Get:8 file:/var/visionworks-tracking-repo Release [2,008 B]
Get:9 https://repo.download.nvidia.com/jetson/common r32.4 InRelease [2,552 B]
Get:10 https://repo.download.nvidia.com/jetson/t186 r32.4 InRelease [2,561 B]
Hit:12 http://ports.ubuntu.com/ubuntu-ports bionic InRelease
Get:14 http://ports.ubuntu.com/ubuntu-ports bionic-updates InRelease [88.7 kB]
Err:9 https://repo.download.nvidia.com/jetson/common r32.4 InRelease
The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 0D296FFB880FB004
Get:17 http://ports.ubuntu.com/ubuntu-ports bionic-backports InRelease [74.6 kB]
Err:10 https://repo.download.nvidia.com/jetson/t186 r32.4 InRelease
The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 0D296FFB880FB004
Get:18 http://ports.ubuntu.com/ubuntu-ports bionic-security InRelease [88.7 kB]
Get:19 http://ports.ubuntu.com/ubuntu-ports bionic-updates/main arm64 DEP-11 Metadata [290 kB]
Get:20 http://ports.ubuntu.com/ubuntu-ports bionic-updates/universe arm64 DEP-11 Metadata [282 kB]
Get:21 http://ports.ubuntu.com/ubuntu-ports bionic-backports/universe arm64 DEP-11 Metadata [9,288 B]
Get:22 http://ports.ubuntu.com/ubuntu-ports bionic-security/main arm64 DEP-11 Metadata [42.7 kB]
Get:23 http://ports.ubuntu.com/ubuntu-ports bionic-security/universe arm64 DEP-11 Metadata [52.2 kB]
Reading package lists… Done
W: GPG error: https://repo.download.nvidia.com/jetson/common r32.4 InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 0D296FFB880FB004
E: The repository ‘https://repo.download.nvidia.com/jetson/common r32.4 InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: https://repo.download.nvidia.com/jetson/t186 r32.4 InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 0D296FFB880FB004
E: The repository ‘https://repo.download.nvidia.com/jetson/t186 r32.4 InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

what’s the problem?
or can I install PyTorch 1.6.0 without upgrading the JetPack?

Please refer to below link if can help:

Hi,

Have you fixed this issue yet?

Please note that there are some dependencies between the PyTorch package and JetPack.
You will need to use the package built with the same JetPack to ensure compatibility.

For the details, please check this topic for information:

Thanks,

I follow the below procedure.
wget https://nvidia.box.com/shared/static/9eptse6jyly1ggt9axbja2yrmj6pbarc.whl -O torch-1.6.0-cp36-cp36m-linux_aarch64.whl
sudo apt-get install python3-pip libopenblas-base libopenmpi-dev
pip3 install Cython
pip3 install numpy torch-1.6.0-cp36-cp36m-linux_aarch64.whl

Then, $python3 and “import torch” returns the below error.

Python 3.6.9 (default, Jul 17 2020, 12:50:27)
[GCC 8.4.0] on linux
Type “help”, “copyright”, “credits” or “license” for more information.

import torch
Traceback (most recent call last):
File “”, line 1, in
File “/home/esal/.local/lib/python3.6/site-packages/torch/init.py”, line 188, in
_load_global_deps()
File “/home/esal/.local/lib/python3.6/site-packages/torch/init.py”, line 141, in _load_global_deps
ctypes.CDLL(lib_path, mode=ctypes.RTLD_GLOBAL)
File “/usr/lib/python3.6/ctypes/init.py”, line 348, in init
self._handle = _dlopen(self._name, mode)
OSError: libcurand.so.10: cannot open shared object file: No such file or directory

Hi,

The package mentioned above requires a JetPack4.4 environment.
Have you setup the device with JetPack4.4.

If yes, could you check if there is a libcurand.so.10 library installed in your environment?

$ sudo find / -iname libcurand.so.10

Thanks.

I don’t know JetPack version. I remember that install the JetPack in Jan. 2020.

$ sudo find / -iname libcurand.so.10
find: ‘/proc/7665’: No such file or directory

the solution is just to re-install JetPack newer version?

If this is installed it will be somewhere within:
/usr/local/cuda-...version.../targets/aarch64-linux/lib/

Flashing will not add this if it is missing. What will add it is if the optional CUDA package is installed. On a system which is a bit older I see:

# dpkg -S /usr/local/cuda-10.0/targets/aarch64-linux/lib/libcurand.so
cuda-curand-dev-10-0: /usr/local/cuda-10.0/targets/aarch64-linux/lib/libcurand.so

This was installed automatically as a dependency when installing CUDA via JetPack/SDKM. Keep in mind that SDKM can have flashing unchecked, and PC packages unchecked, and only the install of CUDA. In more recent releases this can also be installed using the standard “apt-get install ...” mechanism.

Simply, I solved it by installing the latest version of JetPack.
thanks for the reply.