Error of " connecting to nvargus-daemon failed "found when running docker images

I created an image basing on the image of deepstream-5.1 (tag: samples), and I herein with my dockerfile.
Dockerfile (998 Bytes)
I ran the container on the Jetson Xavier NX (Developer Kit Version). And the environment was built by SDK manager. I also show the details as below:
env

My command of start the container was :
docker run -it -v $PWD:/home/env -p 8555:8555 -p 5401:5401 --runtime my_image_name /bin/bash
And I transfered into the container, and found an file missing: libcudart.so.10.2, and after added this file manually, I started my service by the command: yrvideo -c deepstream-app-config.txt, I got an error report as follows:


Furthermore, I can run the service succussfully basing on the system built by official SD images which have installed CUDA, OPENCV, TensorRT and other components。
So, I’m not clear whether some components was missing in this basic environment?

Hope anyone may give some advice for me, thank in advance!

Jetpack 4.6 is not compatible with docker deepstream-5.1
Please check this, Quickstart Guide — DeepStream 6.1.1 Release documentation

I had tested the deepstream6.0, and found same error. I’m not clear whether any components not installed?

Using which Jetpack version?

deepstream6.0 with jetpackage4.6.1。

As the mention error in top that can not find the nvargus-daemon, I think maybe some components are missing?? So could you help to clarify which components are correspond with nvargus-daemon

You should use Deepstream 6.0.1 for JP4.6.1
please check this,
https://docs.nvidia.com/metropolis/deepstream/dev-guide/text/DS_Quickstart.html#platform-and-os-compatibility
It’s nvarguscamersrc.

Thanks.
I did use the deepstream 6.0.1 with JP 4.6.1.
As mentioned before, I installed the JP 4.6.1 without any extra components installed, and pulled the docker images of 5.1 (samples revision), then cause the error of connecting to nvargus-daemon failed. I also changed the docker images to 6.0.1, but still the same problem. So, I supposed the basic environment should be installed the components such as CUDA, TensorRT, OPENCV, which is required by the deepstream images??—But I can see the introduction that the docker images of samples revision have already with CUDA and TensorRT installed. Am’I wrong?

The document you mentioned is from deepstream 6.1
Please add --runtime=nvidia to your docker command to solve cuda library not found issue.
can you find nvarguscamerasrc plugin?
gst-inspect-1.0 nvarguscamerasrc

Sorry, I have reinstall the basic system with CUDA included, and find no such problem.
I just want to make it clear for I was told from others brfore that basic system can be only installed with driver if docker images have included with CUDA.
But now, It seems CUDA is required in basic system even we use docker images of samples revision which is claimed with CUDA inside.
Am I wrong?

As said before
The document you mentioned is from deepstream 6.1

So, you mean the CUDA in basic system is needed for the revision before 6.1?

Yes.

Ok, many thanks!