Error on "import pyds": ImportError: cannot open shared object file: No such file or directory

GPU RTX 3080; Ubuntu 20.04

Previously I completed the course “Building Video AI Applications at the Edge on Jetson Nano” on a Jetson device and nothing went wrong. Now I’m using RTX 3080 but I got a issue on “import pyds”, details as follows:

1. I followed the instructions
echo "sudo docker run --runtime nvidia -it --rm --network host
-v /tmp/.X11-unix/:/tmp/.X11-unix
-v /tmp/argus_socket:/tmp/argus_socket
-v ~/my_apps:/dli/task/my_apps
–device /dev/video0 " >

chmod +x


and logged in to the jupyterLab server.

2. In 01-ObjDetect.ipynb, I run the cell
“# Check usage of the test1 app with the help option
!cd $PYTHON_APPS/deepstream-test1-rtsp-out
&& python3 --help”

and got the following error message:
"Traceback (most recent call last):
File “”, line 31, in
import pyds
ImportError: cannot open shared object file: No such file or directory

I found some similar issues on the forums but none of them worked for my case.
Solutions I tried:

    After changing “import pyds” to “from bindings.x86_64 import pyds”, I got error “cannot find bindings”
    I followed the instructions but still not working.
  3. I can find under “~/.local/lib/python3.8/site-packages”. (I installed it using

I got no problem on my Nano device (Ubuntu 18.04), but it cannot go through on RTX. I saw the course uses Deepstream 6.0.1. Is it because Deepstream 6.0.1 doesn’t work on Ubuntu 20.04? I’m really confused…

Can you get the output of file ~/.local/lib/python3.8/dist-packages/ and ldd ~/.local/lib/python3.8/dist-packages/

“file” output: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, BuildID[sha1]=1691ddbaa205a53eb0c0d2bc891317baedf65bc2, not stripped

“ldd” output: (0x00007fffbe9cc000)| => /lib/x86_64-linux-gnu/ (0x00007fd31db31000)| => /lib/x86_64-linux-gnu/ (0x00007fd31d9ea000)| => /lib/x86_64-linux-gnu/ (0x00007fd31d8c1000)|
/opt/nvidia/deepstream/deepstream-6.1/lib/ (0x00007fd31d8b6000)|
/opt/nvidia/deepstream/deepstream-6.1/lib/ (0x00007fd31d8af000)|
/opt/nvidia/deepstream/deepstream-6.1/lib/ (0x00007fd31d8a6000)| => /lib/x86_64-linux-gnu/ (0x00007fd31d6c2000)| => /lib/x86_64-linux-gnu/ (0x00007fd31d6a7000)| => /lib/x86_64-linux-gnu/ (0x00007fd31d4b5000)| => /lib/x86_64-linux-gnu/ (0x00007fd31d487000)| => /lib/x86_64-linux-gnu/ (0x00007fd31d46b000)| => /lib/x86_64-linux-gnu/ (0x00007fd31d448000)| => /lib/x86_64-linux-gnu/ (0x00007fd31d440000)| => /lib/x86_64-linux-gnu/ (0x00007fd31d43b000)| => /lib/x86_64-linux-gnu/ (0x00007fd31d2ec000)| => /lib/x86_64-linux-gnu/ (0x00007fd31d28c000)| => /lib/x86_64-linux-gnu/ (0x00007fd31d286000)| => /lib/x86_64-linux-gnu/ (0x00007fd31d213000)| => /usr/local/cuda-11.6/lib64/ (0x00007fd31cf6d000)| => ///opt/nvidia/deepstream/deepstream-6.1/lib/ (0x00007fd31cf67000)|
/lib64/ (0x00007fd31e225000)| => /lib/x86_64-linux-gnu/ (0x00007fd31cf5b000)| => /lib/x86_64-linux-gnu/ (0x00007fd31cf51000)|

Oh, this course is for Jetson devices, not for dGPU. I do not think you can use it for dGPU.

There is no update from you for a period, assuming this is not an issue anymore.
Hence we are closing this topic. If need further support, please open a new one.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.