Error parsing LReLU_TRT plugin on Jetson TX2

Description

Getting an error when parsing LeakyRelu node using UFF parser on Jetson TX2:

[TensorRT] INFO: UFFParser: parsing leaky_re_lu_1/LeakyRelu
[TensorRT] INTERNAL ERROR: Assertion failed: fc->nbFields == 1
lReluPlugin.cpp:130
Aborting...

Environment

Platform: Jetson TX2
Jetpack Version: 4.2.2
TensorRT Version: 5.1.6

Steps To Reproduce

  1. Model’s architecture is YOLOv3 (tiny)
  2. Replaced LeakyRelu with LReLU_TRT op using graphsurgeon (source: Converting Neural Network To TensorRT . Part 1 Using Existing Plugins. | by Roman Sokolkov | Medium)
  3. While converting to an engine from UFF file I’m getting an error: Assertion failed: fc->nbFields == 1 lReluPlugin.cpp:130

Even with official example I’m getting same error on Jetson TX2.

Everything works perfectly on Tensorrt 5.1.5 (in official container: nvidia/tensorrt:19.07-py3).

I’d be very helpful for any hints :) Maybe I’m missing something?

The reason was in line 42 (graphsurgeon/node_manipulation.py::update_node):
node.attr["dtype"].type = 1 # AB 13.8.2020

Commented it and everything worked.

1 Like

Hi,
This looks like a Jetson issue. Please refer to the below samlples in case useful.

For any further assistance, we recommend you to raise it to the respective platform from the below link

Thanks!

1 Like