Error response from daemon when I tried to run deepstream

I downloaded deepstream via docker. After that, I tried to run it but get this error. Also I get this error when i try to run l4t-pytorch container

sudo docker run -it --rm --net=host --runtime nvidia -e DISPLAY=$DISPLAY -w /opt/nvidia/deepstream/deepstream-5.1 -v /tmp/.X11-unix/:/tmp/.X11-unix
nvcr.io/nvidia/deepstream-l4t:5.1-21.02-samples


Unable to find image '[nvcr.io/nvidia/deepstream-l4t:5.1-21.02-samples](http://nvcr.io/nvidia/deepstream-l4t:5.1-21.02-samples)' locally

5.1-21.02-samples: Pulling from nvidia/deepstream-l4t

5000a6c32c5a: Already exists

8e855b69096a: Already exists

8db8dbbd4bb9: Already exists

833dc3235950: Already exists

f79d264135a3: Already exists

1c40f77bb35b: Already exists

1990ecf0bfb7: Already exists

c8ffbfd7f0aa: Already exists

ba785779122a: Already exists

024ce79b6790: Already exists

9b09da3b5483: Already exists

17f974a43cf9: Already exists

211b56b73ff1: Already exists

78aca4be1f3b: Already exists

95f34310bbda: Already exists

678c9d1557e9: Already exists

ec17ad7cab01: Already exists

08fb1eee5328: Already exists

0440ae963ad6: Already exists

a4b1c92534f2: Already exists

bfc4e122bcd7: Pull complete

bf01cdd77e02: Pull complete

fe83596186d7: Pull complete

Digest: sha256:4005a965b9a6e1cec545032e72d0cf01ef6202685a2ba0613369494c22181138

Status: Downloaded newer image for [nvcr.io/nvidia/deepstream-l4t:5.1-21.02-samples](http://nvcr.io/nvidia/deepstream-l4t:5.1-21.02-samples)

docker: Error response from daemon: OCI runtime create failed: container_linux.go:380: starting container process caused: process_linux.go:545: container init caused: Running hook #0:: error running hook: exit status 1, stdout: , stderr: nvidia-container-cli: initialization error: driver error: failed to process request: unknown.

Hi @grkem.yilmaz, does the version of JetPack-L4T that you are running match the version of the L4T that the container was built for? You can check your L4T version with cat /etc/nv_tegra_release

Take l4t-pytorch for example - if you are on L4T R32.5.0, you should run nvcr.io/nvidia/l4t-pytorch:r32.5.0-pth1.6-py3. The exception is that L4T R32.5.1 also uses the R32.5.0 containers.

It looks like from here that the deepstream-l4t:5.1 is meant to run on JetPack 4.5.1 / L4T R32.5.1.

My l4t version is 5.1

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

Hi,
Please share the information:

cat /etc/nv_tegra_release

Hi, I have the same issue, here is the nv_tegra_release information:

# R32 (release), REVISION: 5.1, GCID: 27362550, BOARD: t210ref, EABI: aarch64, DATE: Wed May 19 18:07:59 UTC 2021

Hi yinonb11,

Please help to open a new topic if it’s still an issue.

Thanks