Error setting up ISAAC 2020.1NX

I’ve downloaded and unpacked ISAAC 2020.1NX, and I’m following the setup instructions at https://docs.nvidia.com/isaac/isaac/doc/setup.html.

Running the step engine/build/scripts/install_dependencies.sh I get the following error:
Running command python setup.py egg_info
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-install-r9dc_d8m/pycapnp/setup.py”, line 12, in
import pkgconfig
ModuleNotFoundError: No module named ‘pkgconfig’
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.

I tried “apt install python-pip” and “pip install pkgconfig” but that didn’t solve the problem.

System is running Ubuntu 18.04.

Can anyone suggest a fix?

I ran into the same problem. It looks like the ISAAC install_dependencies script uses python3, so I was able to fix it by running:

python3 -m pip install pkgconfig

(The command you ran would have installed pkgconfig for python 2 instead of python 3)

I also had to manually install Cython and cmake:

python3 -m pip install Cython
sudo apt install cmake

Thanks! Perhaps NVIDIA could either update the setup document or update the install_dependencies script to install those.

Thanks, @noaht11! I was able to reproduce the problem with pycapnp on a clean Ubuntu 18.04 container and I filed a bug to track the fix into an Isaac SDK release.