ERROR: too many resources requested for launch img2col when use pytorch

I’m using pytorch on a tx2 with jetpack3.2.
The pytorch (0.3.0) is compiled from source as https://github.com/dusty-nv/jetson-reinforcement/blob/master/CMakePreBuild.sh.

I use it to do a forward computing. In my PC with a 1080ti, it needs 3GB memory to do this forward computing. But in tx2, it always gives me this “too many resources requested error” when the torch module do forward computing.

That’s why?

Hi,

Could you reboot the device and try it again?
Thanks.

I’m running into the same error when I try to run a pretrained PyTorch network on some imagenet images.
I compiled PyTorch v0.4.0 from Source and run

python examples/imagenet_eval.py ../../datasets/imagenet -a vgg16 -b 20 -e

at the root of this repo: https://github.com/Cadene/pretrained-models.pytorch
Setting number of workers to zero or one doesn’t help it.

I also encountered memory issues on other PyTorch examples (SIGKILL (n_workers = 0) or “Connection Refused” (n_workers > 0) on worker shutdown in DataLoader).

Any ideas?

Hi,

Could you set batchsize=1 and try it again?

python examples/imagenet_eval.py ../../datasets/imagenet -a vgg16 -b 1 -e

Thanks.

Hi AastaLLL,
thank you for your reply.
For batchsize=1 it results in the same error.

Hi,

Could you monitor the memory utilization with tegrastats and share data with us?

sudo ./tegrastats

Thanks.