ERROR: torch-1.6.0-cp36-cp36m-linux_aarch64.whl is not asupported wheel on this platform

I intall JP4.6.1 in my device but i find there are no pytorch version correspond to JP4.6.1.
I checked the version in this website PyTorch for Jetson - version 1.11 now available. And download the package “torch-1.6.0-cp36-cp36m-linux_aarch64.whl”.
But install failed in my NX:

pip install torch-1.6.0-cp36-cp36m-linux_aarch64.whl

ERROR: torch-1.6.0-cp36-cp36m-linux_aarch64.whl is not asupported wheel on this platform.

Since Jetson NX16GB only support JetPack4.6.1 and newer version of Jetpack, does this mean i must install JP5.0 or JP5.0.1 to get the corresponding version of pytorch? But my code needs lower version of pytorch.


It is expected to work.
Do you run it like the below command?

$ wget -O torch-1.6.0-cp36-cp36m-linux_aarch64.whl
$ sudo apt-get install python3-pip libopenblas-base libopenmpi-dev libomp-dev
$ pip3 install Cython
$ pip3 install numpy torch-1.8.0-cp36-cp36m-linux_aarch64.whl


Thank you for answer, AastaLLL.
I use conda to build the python environment, but conda (linux-aarch64 version) only support python 3.7 and other newer version of python. So i install python 3.7 and get the above error.

Then i try to use pip to install and finally succeed. But i think conda is a very useful tool because it can integrate many packages for running code. So how can i use conda in NX to install pytorch or other package? ~~

@bo.qu we only build the PyTorch wheels for the default version of Python that comes with Ubuntu, and on JetPack 4.x that’s Ubuntu 18.04 and Python 3.6. However by following the instructions in this post, you should be able to rebuild PyTorch for Python 3.7 should you desire:

Thank you for reply.
Do you mean that i can follow “Build from Source” in your post to install any version of pytorch with different version of python? And just in the “Build wheel for Python 3.6” step using my own python environment.

Yes that is correct, you can give those instructions a try except to substitute Python 3.7 instead of Python 3.6.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.