ERROR: [TRT]: Network has dynamic or shape inputs, but no os been defined

When I deployed deepstream according to the practice of blog, I thought I followed the steps of blog, but the model engine transformation failed. I tried to change TRT_ The attempt to set the position of pose.onnx to dynamic size seems to have failed, and the engine has not been started successfully.
WARNING: [TRT]: onnx2trt_utils.cpp:220: Your ONNX model has been generated with INT64 weights, while TensorRT does not natively support INT64. Attempting to cast down to INT32.
ERROR: [TRT]: Network has dynamic or shape inputs, but no optimization profile has been defined.
ERROR: [TRT]: Network validation failed.
ERROR: Build engine failed from config file
ERROR: failed to build trt engine.

when I modify the 【property】,add:force-implici-batch-dim=1

the problem changed:
Assertion failed: !_importer_ctx.network()->hasImplicitBatchDimension() && “This version of the ONNX parser only supports TensorRT INetworkDefinitions with an explicit batch dimension. Please ensure the network was created using the EXPLICIT_BATCH NetworkDefinitionCreationFlag.”
ERROR: Failed to parse onnx file
ERROR: failed to build network since parsing model errors.
ERROR: failed to build network.

Sorry for the late response, is this still an issue to support?

Yes, that’s still a problem. You once asked me to try to upgrade the deepstream SDK, maybe not the problem, I ran the trt_pose successfully, but running deepstream-pose-the-impaction made these errors and the engine didn’t convert successfully.

Hi @804143956
sorry for delay! could you share the pgie config file?

Thanks!

Thank you, I put the deepstream-pose-image in the stepstream’s sample-apps, and I just modified the deepstream-pose-image config file, below is my config file.


below is pgie file

which dimension of your onnx model are dynamic besides batch?
for batch dynamic onnx model, “force-implici-batch-dim=1” is not needed.
yolov4 - Google Drive is a reference for yolov4 / DS inference based on batch dynamic yolov4 onnx model