Error trying to build stereo_dummy

Trying to build the stereo_dummy app. Getting this error. Error loading package ‘’: Encountered error when reading extension file "bazel/repositories.bzl : no such package ‘@com_github_googlecartographer_cartographer//’ error loading package ‘external’ : Could not load //external package. Tried building cartographer standalone that didn’t help.

did a bazel build in the isaac directory and now bazel build //apps/samples/stereo_dummy is working.

When building stereo_dummy, I get a lot of similar errors:

Couldn't build file external/com_github_gflags_gflags/_objs/gflags/gflags.o: undeclared inclusion(s) in rule '@com_github_gflags_gflags//:gflags':
this rule is missing dependency declarations for the following files included by 'external/com_github_gflags_gflags/src/gflags.cc':
  '/usr/lib/gcc/x86_64-linux-gnu/8/include/stddef.h'
  '/usr/lib/gcc/x86_64-linux-gnu/8/include/stdarg.h'
  '/usr/lib/gcc/x86_64-linux-gnu/8/include/stdint.h'

It seems that the build system does not understand external system headers.
My system:

user@isaac:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 18.10
Release:	18.10
Codename:	cosmic

user@isaac:~$ uname -a
Linux isaac 4.18.0-16-generic #17-Ubuntu SMP Fri Feb 8 00:06:57 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

user@isaac:~$ bazel version
WARNING: --batch mode is deprecated. Please instead explicitly shut down your Bazel server using the command "bazel shutdown".
Build label: 0.19.2
Build target: bazel-out/k8-opt/bin/src/main/java/com/google/devtools/build/lib/bazel/BazelServer_deploy.jar
Build time: Mon Nov 19 16:25:09 2018 (1542644709)
Build timestamp: 1542644709
Build timestamp as int: 1542644709

I got the same issue.

Does anyone find the way to fix?

was having permission issue with /home/username/.cache/bazel,
but resolved via assigning correct permissions to the folder, but still seems the issue with the cartographer. Tried to build the cartographer.processing

bob@desktop:~/isaac$ engine/build/scripts/install_dependencies.sh

bazel build //apps/samples/stereo_dummy is working

Please tell us what is your operating system and which compiler? Can you send a small fragment of the output of the command?

bazel build -s //apps/samples/stereo_dumm

(with the key -s)

UPD: Perhaps the whole thing in this condition: “Isaac currently only supports 18.04 LTS”

exactly!
18.04 starts it fine from a fresh install.
Does anyone have an idea of how to get the stereo_dumm to show stereolabs zed camera output instead of dummy_camera?
UPD: reference found https://devtalk.nvidia.com/default/topic/1049582/isaac-sdk/isaac-navigation-stack-stereo-camera-support/

Here is the Error I receive:

david@davidml:~/isaac$ bazel build -s //apps/samples/stereo_dummy
ERROR: /home/david/isaac/packages/dummies/BUILD:5:12: Configurable attribute “data” doesn’t match this configuration (would a default condition help?).
Conditions checked:
//engine/build:platform_x86_64
//engine/build:platform_jetpack42
ERROR: Analysis of target ‘//apps/samples/stereo_dummy:stereo_dummy’ failed; build aborted:

/home/david/isaac/packages/dummies/BUILD:5:12: Configurable attribute “data” doesn’t match this configuration (would a default condition help?).
Conditions checked:
//engine/build:platform_x86_64
//engine/build:platform_jetpack42
INFO: Elapsed time: 0.059s
INFO: 0 processes.
FAILED: Build did NOT complete successfully (0 packages loaded, 0 targets conf
igured)

My System:

david@davidml:~/isaac$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic
david@davidml:~/isaac$ uname -a
Linux davidml 4.15.0-47-generic #50-Ubuntu SMP Wed Mar 13 10:44:52 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
david@davidml:~/isaac$ bazel version
Build label: 0.19.2
Build target: bazel-out/k8-opt/bin/src/main/java/com/google/devtools/build/lib/bazel/BazelServer_deploy.jar
Build time: Mon Nov 19 16:25:09 2018 (1542644709)
Build timestamp: 1542644709
Build timestamp as int: 1542644709
david@davidml:~/isaac$

Try reinstalling the dependencies using command:

bob@desktop:~/isaac$ engine/build/scripts/install_dependencies.sh

UPD: My output of command bazel build -s //apps/samples/stereo_dummy is not at all like yours:

user@isaac:~/isaac$ bazel build -s //apps/samples/stereo_dummy
Extracting Bazel installation...
Starting local Bazel server and connecting to it...
INFO: Repository rule 'com_github_googlecartographer_cartographer' returned: {"remote": "https://github.com/googlecartographer/cartographer.git", "commit": "b6b41e9b173ea2e49e606f1e0d54d6d57ed421e3", "shallow_since": "2018-08-10", "init_submodules": False, "verbose": False, "strip_prefix": "", "patches": [], "patch_tool": "patch", "patch_args": ["-p0"], "patch_cmds": [], "name": "com_github_googlecartographer_cartographer"}
INFO: Repository rule 'com_github_nelhage_rules_boost' returned: {"remote": "https://github.com/nelhage/rules_boost.git", "commit": "bd05f7b51d25396f30639d31fa78b55a3c1db182", "shallow_since": "2018-08-09", "init_submodules": False, "verbose": False, "strip_prefix": "", "patches": [], "patch_tool": "patch", "patch_args": ["-p0"], "patch_cmds": [], "name": "com_github_nelhage_rules_boost"}
INFO: Repository rule 'com_github_gflags_gflags' returned: {"remote": "https://github.com/gflags/gflags.git", "commit": "e292e0452fcfd5a8ae055b59052fc041cbab4abf", "shallow_since": "2018-01-07", "init_submodules": False, "verbose": False, "strip_prefix": "", "patches": [], "patch_tool": "patch", "patch_args": ["-p0"], "patch_cmds": [], "name": "com_github_gflags_gflags"}
INFO: SHA256 (https://s3.amazonaws.com/rdk-public/sight/isaac_assets.zip) = 032d56b65d17acf360cab1145e57cdeb0a0d2e25814624a90d44766e624e40f1
WARNING: /home/user/isaac/packages/viewers/BUILD:14:12: in srcs attribute of cc_binary rule //packages/viewers:libviewers_module.so: please do not import '//packages_x86_64/viewers:libviewers_module.so' directly. You should either move the file to this package or depend on an appropriate rule there
INFO: Analysed target //apps/samples/stereo_dummy:stereo_dummy (61 packages loaded, 2865 targets configured).
INFO: Found 1 target...
SUBCOMMAND: # @libjpeg//:configure_internal [action 'Executing genrule @libjpeg//:configure_internal']
(cd /home/user/.cache/bazel/_bazel_user/8a9aec4f1f06e6ffe31dee333a3c4a02/execroot/isaac && \
  exec env - \
    PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin \
    target_platform=x86_64 \
  /bin/bash -c 'source external/bazel_tools/tools/genrule/genrule-setup.sh; cp bazel-out/k8-opt/genfiles/external/libjpeg/jconfigint_nowin.h bazel-out/k8-opt/genfiles/external/libjpeg/jconfigint.h')

I have the same issue.

Installed the Jetpack 4.2 on a fresh Ubuntu 18.04 and Jetson Xavier
Installed Isaac SDK
Compiled Isaac SIM
Ran the above example (and tried other examples too) and got the same error as mentioned above.

~/isaac$ bazel run //apps/samples/stereo_dummy
ERROR: /home/x/isaac/packages/dummies/BUILD:5:12: Configurable attribute “data” doesn’t match this configuration (would a default condition help?).
Conditions checked:
//engine/build:platform_x86_64
//engine/build:platform_jetpack42
ERROR: Analysis of target ‘//apps/samples/stereo_dummy:stereo_dummy’ failed; build aborted:

/home/x/isaac/packages/dummies/BUILD:5:12: Configurable attribute “data” doesn’t match this configuration (would a default condition help?).
Conditions checked:
//engine/build:platform_x86_64
//engine/build:platform_jetpack42
INFO: Elapsed time: 0.090s
INFO: 0 processes.
FAILED: Build did NOT complete successfully (0 packages loaded, 0 targets configured)
FAILED: Build did NOT complete successfully (0 packages loaded, 0 targets configured)

@Andrey1984: stereo_dummy is really only a test app. You might want to look at zed sample app instead.

@tompos/@roboticsintelligence: Are you compiling on the Jetson? We only support compilation on host x86 PC and cross-compilation for Jetson.

I have the same issue when I try to build this example on my workstation running Ubuntu 18.04:

~/workspace/isaac$ bazel build //apps/samples/stereo_dummy
Starting local Bazel server and connecting to it...
ERROR: /home/cyril/workspace/isaac/packages/dummies/BUILD:5:12: Configurable attribute "data" doesn't match this configuration (would a default condition help?).
Conditions checked:
 //engine/build:platform_x86_64
 //engine/build:platform_jetpack42
ERROR: Analysis of target '//apps/samples/stereo_dummy:stereo_dummy' failed; build aborted: 

/home/cyril/workspace/isaac/packages/dummies/BUILD:5:12: Configurable attribute "data" doesn't match this configuration (would a default condition help?).
Conditions checked:
 //engine/build:platform_x86_64
 //engine/build:platform_jetpack42
INFO: Elapsed time: 1.094s
INFO: 0 processes.
FAILED: Build did NOT complete successfully (11 packages loaded, 42 targets co\
nfigured)
    currently loading: @local_config_sh//

Anybody found a way to solve that ?

@Cyril_J:
What is the bazel version you have? Bazel v0.19.2 is recommended.
Does installing dependencies (running install_dependency.sh) help?
Does ‘bazel build apps/samples/stereo_dummy --config x86_64’ build properly?

@yangl Thanks for your reply, I have the correct bazel version:

~/workspace/isaac$ bazel version
Build label: 0.19.2
Build target: bazel-out/k8-opt/bin/src/main/java/com/google/devtools/build/lib/bazel/BazelServer_deploy.jar
Build time: Mon Nov 19 16:25:09 2018 (1542644709)
Build timestamp: 1542644709
Build timestamp as int: 1542644709

After I relaunched the install_dependency.sh script, everything seems fine, here is a summary of the Bazel part:

Bazel installer
---------------
...
...
## Build informations
   - [Commit](https://github.com/bazelbuild/bazel/commit/6d6633a)
Uncompressing.......

Bazel is now installed!

Make sure you have "/usr/local/bin" in your path. You can also activate bash
completion by adding the following line to your ~/.bashrc:
  source /usr/local/lib/bazel/bin/bazel-complete.bash

See http://bazel.build/docs/getting-started.html to start a new project!
Installation Succeeded

Here is my $PATH:

~$ echo $PATH
/usr/local/cuda-10.1/bin:/home/cyril/anaconda3/bin:/home/cyril/workspace/vulkan/1.1.106.0/x86_64/bin:/opt/ros/melodic/bin:/home/cyril/.local/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin

I also source bazel-complete.bash in my .bashrc.

Here is the result of adding the config parameter you suggested:

~/workspace/isaac$ bazel build //apps/samples/stereo_dummy --config x86_64
INFO: Options provided by the client:
  Inherited 'common' options: --isatty=1 --terminal_columns=211
ERROR: Config value x86_64 is not defined in any .rc file

And

~/workspace/isaac$ bazel build //apps/samples/stereo_dummy

still gives the same error, which I have for all bazel projects by the way.
I opened another thread for that, since this one has an answer that has been accepted by the author:
https://devtalk.nvidia.com/default/topic/1050738/sdk/error-with-bazel-when-building-the-sample-demos/

Any clue as to why my desktop seems to not be detected as a x86_64 ?

Issue solved, the answer is in the other thread :
https://devtalk.nvidia.com/default/topic/1050738/sdk/error-with-bazel-when-building-the-sample-demos/

make sure to include ./bazelrc int the issac root folder, often that file isnt copied properly