ERROR: Unable to load the 'nvidia-drm' kernel module

When I install a NVIDIA driver on a new installed RHEL7 I get following error: “ERROR: Unable to load the ‘nvidia-drm’ kernel module” at the end of the driver installation.

In the past I have resolved this problem with reinstalling the RHEL.

But I would like to solve this problem since reinstalling did not help.

  1. I have installed a RHEL7.4 and upgraded it to RHEL7.9
  2. I installed following packages:

rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm

yum -y install epel-release
yum -y install synergy-plus.x86_64
yum -y install mc dos2unix unix2dos
yum -y install kernel-devel
yum -y install openmpi-devel.x86_64
yum groupinstall “Development Tools”
yum -y install kernel-devel kernel-headers dkms
yum -y install devtoolset-7
yum -y install gnuplot
yum -y install nfs-utils

  1. Then I disabled the nouveau driver what was installed with redhat:

sed -i ‘s/GRUB_CMDLINE_LINUX=“crashkernel=auto rd.lvm.lv=vg00/lv00 biosdevname=0 net.ifnames=0 rhgb quiet”/GRUB_CMDLINE_LINUX=“crashkernel=auto rd.lvm.lv=vg00/lv00 biosdevname=0 net.ifnames=0 rhgb quie t rd.driver.blacklist=nouveau nouveau.modeset=0”/’ /etc/default/grub
echo “blacklist nouveau” > /etc/modprobe.d/blacklist.conf
mv /boot/initramfs-(uname -r).img /boot/initramfs-(uname -r)-nouveau.img
dracut /boot/initramfs-(uname -r).img (uname -r)

  1. Reboot
  2. Installed the nvidia driver:

systemctl isolate multi-user.target
/bin/bash /tmp/NVIDIA-Linux-x86_64-430.50.run -sZ –dkms
running it manual without the parameters gives the same result:

  1. The error appears at the end of the installation. And followed by the following message:

ERROR: Installation has failed. Please see the file ‘/var/log/nvidia-installer.log’ for details. You may find suggestions on fixing

installation problems in the README available on the Linux driver download page at www.nvidia.com.

  1. In the mentioned file there is information attached below.
  2. NOTICE that using the 460.39 (Latest Long Term) version driver gives the same result

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

#-> nvidia-bug-report.sh

nvidia-bug-report.sh will now collect information about your
system and create the file ‘nvidia-bug-report.log.gz’ in the current
directory. It may take several seconds to run. In some
cases, it may hang trying to capture data generated dynamically
by the Linux kernel and/or the NVIDIA kernel module. While
the bug report log file will be incomplete if this happens, it
may still contain enough data to diagnose your problem.

If nvidia-bug-report.sh hangs, consider running with the --safe-mode
and --extra-system-data command line arguments.

Please include the ‘nvidia-bug-report.log.gz’ log file when reporting
your bug via the NVIDIA Linux forum (see devtalk.nvidia.com)
or by sending email to ‘linux-bugs@nvidia.com’.

By delivering ‘nvidia-bug-report.log.gz’ to NVIDIA, you acknowledge
and agree that personal information may inadvertently be included in
the output. Notwithstanding the foregoing, NVIDIA will use the
output only for the purpose of investigating your reported issue.

Running nvidia-bug-report.sh… complete.

[root@wrhels4re2167:/root]#
#-> nvidia-bug-report.log.gz (93.6 KB)

You have secure boot enabled. Please disable it in bios settings. Otherwise, you’ll have to sign the driver.

Normally it is diabled in the bios as described in the Lenovo instructions to install redhat linux

dmesg:
[ 0.000000] Secure boot enabled