==ERROR== Unable to write to file pr.ncu-rep. Please verify this file is not locked, and writable

Host : window 10
target : linux
nsight compute 24.1.1
deployment directory : /home/gil/

Im struggling to solve this issue, but it’s hard
I tried many possible cases

  1. make that output file shared
  2. give authority to all

but they didn’t work

actually Im not sure what’s proper to be put down in

  1. application executable
  2. working directory
  3. command line argument
  4. environment
  5. output file
  6. deployment directory

thank you


Hi, @mymok71

I noticed that you are using user sangbeom to SSH the target, and you are using /home/gil as the deployment and work directory.

Can you do below to check if any other info can be printed

  1. copy the command line from “Command Line” under “Common” tab
  2. SSH login into the linux machine with user sangbeom
  3. execute the command line directly

Thank you for helping me

still same problem is occurred

sangbeom is sudo account, so I used this one

Hi, @mymok71

This still seems a file permission issue.
Can you just run /home/gil/…/ncu /home/gil/…/main.py --text “s” to see if the report can be generated ?

Also, do you have to set the working directory under this “gil” user ?

Do you mean I try running like this? (in xshell)


there’s no any report

when I use “gil” user,
I got different message like below


My working directory is where my python is.
I set my working directory under “gil” user

This is my Deployment directory

and I made pr.ncu-rep on my /home/gil/ (linux server)
and also made pr.ncu-rep on C:\Users\IDSL\Desktop\nsight_compute_result (window host)

Thanks for trying.
From the screenshot you add, the error message has changed. The original “Unable to write” issue is gone by using user ‘gil’ to SSH login.

Do you mean I try running like this? (in xshell)
-------------------Here you just executed your python script, please execute $ncu python main.py --text ‘s’. For ‘ncu’, please use its absolute path.

By the way, is there any kernel usage in your python script ? Can you share the python script for us to repro ?

Thank you for your kindness

I tired like you said
I think it worked

I wonder how to modify nsight compute system window : connect to process

of course I can share my repo
gpt-2-Pytorch.zip (3.0 MB)

Hi, @mymok71

The binary for Nsight Compute is ‘ncu’ not ‘pr.ncu-rep’. You are using the wrong command line.
Please execute

/home/gil/target/linux-desktop-glibc_2_11_3-x64/ncu python main.py --text ‘s’

Thank you for quick reply

I changed my file pr.ncu ( /home/gil/gpt-2-Pytorch/pr.ncu )
and I tried again like below

it didn’t work with same symptom.

This is my window : connect to process


and error message

I think I’ve done something wrong with my “window : connect to process”
Can you tell me what it is proper to write down in

I wrote

Application : my executable python script
Working Directory : where my python is
Command line Arguement : commands

Output File : where my pr.nuc is in my host PC

thank you

Hi, @mymok71

In application executable, please choose the python executable binary.
In command line, please put your python script and its parameter.

@veraj
Thank you for your help

I finally made to launch the process

but I’m facing different error
about NVIDIA Development Tools Solutions - ERR_NVGPUCTRPERM: Permission issue with Performance Counters

anyway, I really appreciate everything you’ve done

Hi, @mymok71

It is my pleasure to be able to help.
For ERR_NVGPUCTRPERM, you can refer NVIDIA Development Tools Solutions - | NVIDIA Developer

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.