Error updating from nvidia repos using apt update on dgx station v100


We’re running apt update on the dgx station (V100 ubuntu 18.04 bionic) to get the latest nvidia drivers.
We get an error on the nvidia repo. this claims theres no public key but the repo does not seem to exist either:
(I replaced “http” with “htt.” to go around the forum limit on links for new users given they are not meant to be links)

Err:5 htt.:// bionic InRelease
The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 208CE844D9F220AD
W: GPG error: htt.:// bionic InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 208CE844D9F220AD
E: The repository ‘htt.:// bionic InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Has this nvidia dgx repo changed ? because we’re getting a 404 when manually trying to access it.
The dgx repo file
looks like this:
deb httd:// bionic main multiverse restricted universe

While browsing through the forum I found one looking like this for an A100 DGX:
deb htt.:// focal common dgx
deb htt.:// focal-updates common dgx

Any idea on what we are doing wrong?
Thanks for any help

Hi @damien_dgxst ! Yes, the keys have changed. Can you follow DGX OS 4 Server Software Release Notes :: DGX Systems Documentation and see if the problem persists?


Thanks ScottE,

I’ve tried this but on step 2 to install the packages
i get this error:

dam@DGX-Station:~/Downloads$ sudo dpkg --force-confnew -i ./nvidia-repo-keys_22.04-1_all.deb  ./dgx-repo_1.0-5_amd64.deb
(Reading database ... 400761 files and directories currently installed.)
Preparing to unpack .../nvidia-repo-keys_22.04-1_all.deb ...
Unpacking nvidia-repo-keys (22.04-1) over (22.04-1) ...
Preparing to unpack ./dgx-repo_1.0-5_amd64.deb ...
Unpacking dgx-repo (1.0-5) ...
dpkg: error processing archive ./dgx-repo_1.0-5_amd64.deb (--install):
 trying to overwrite '/etc/apt/preferences.d/nvidia', which is also in package dgxstation-repo 1.0-4
Setting up nvidia-repo-keys (22.04-1) ...
Errors were encountered while processing:


Is this because this is the dgx server os repo and we’re trying to update our dgxstation repo?

or are we expected to change repos?

Thanks for any clarification

My apologies, I pointed to the wrong documentation. I should have used DGX OS 4 Desktop Software Release Notes :: DGX Systems Documentation (the DGX Station version).

(In my defense, for DGX BaseOS 5.x, we unified things so there’s no longer a Server/Station release! :-) )

I think now you’ll need to uninstall/purge the dgx-repo package, and install the dgxstation-repo package per the release notes.

Thanks ScottE,
I didnt have to purge the server repo as it didnt get installed.
rotating the keys worked now though which is progress thanks.

Installing r418 as in step2 worked this time,
However we really need cuda 11+ so I understand we need to upgrade to r450 as we’re still on os4. as suggested in step 3:

  1. Optional: To move to the R450 package, after the R418 repository is installed, issue the following command:

$ sudo apt install -y dgxstation-bionic-r450+cuda11.0-repo

However i get this error:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Package dgxstation-bionic-r450+cuda11.0-repo is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package ‘dgxstation-bionic-r450+cuda11.0-repo’ has no installation candidate

Any which of the hypotheses is the problem?

Note that a previous apt-upgrade installed the 470 drivers and cuda 11.3 independantly of the dgxstation repo.
Will the install overwrite those , or do they need to be purged manually ?

Also for information is OS5 available to install for all dgx stations ?

update: we solved the r450 repo issue, we had to run a purge on the old r418 first.