Error Using Deepstream Pose Estimation as Secondary Model

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) Nvidia T4 GPU
• DeepStream Version 5.0
• TensorRT Version 7.0
• NVIDIA GPU Driver Version (valid for GPU only) 460.56
• Issue Type( questions, new requirements, bugs) bug

I was using the Pose Estimation Example found here . It all worked great.

I added a People Detection Model before the PGIE model (pose estimation model). If both models are working in primary mode, results are as expected and all is good.

However, I want to use the Pose Estimation Model as a secondary model for the People Detection model. This is to ensure that the resultant skeleton is for a single person only (since it was confusing 2 people when they appear at the same time as in the image below).


When I changed the process-mode of PGIE to secondary, the pipeline launches without actually running any inference on the file source (GPU util is 0 as attached) and it never finishes.

I attached the config files of the people detection model and pose estimation model.

Is there any mistake I am doing? Or is the desired scenario not applicable?

deepstream_pose_estimation_config.txt (1.9 KB)
config_infer_primary_peoplenet_detection.txt (3.7 KB)


Could you add “operate-on-gie-id=11” in deepstream_pose_estimation_config.txt?

This “11” is from “gie-unique-id=11” in config_infer_primary_peoplenet_detection.txt

I tried that but nothing changed. The pipeline launches but it doesn’t run the processing and never finishes.

Is it convenient for you to share the repo package?
PS: You could mail it to me

Thanks for following up.

The link for the repo is here

It needs some extra commands to replicate the whole environment. However, these commands are mentioned in the beginning of the Readme file

since you already have the repo, could you just share the whole package so that I can jurt run and repo?


@mchi How can I share it with you? Can you give me an email to share a drive folder with you?

Hi @mohammad1 ,
I made the change as I mentioned in Error Using Deepstream Pose Estimation as Secondary Model - #3 by mchi , I can see output as below. From this output, I think, pose estimation is working on the object, but the post-processing draw the lines on the wrong place (on the frame instead of the detected objects).