Error using Isaac ROS Pose Estimation

Dear NVIDIA forum members,

I am encountering an error with " Isaac ROS Pose Estimation". When I launch the node and replay the provided example bag, I continuously receive the following error message:

[dope_decoder]: [NitrosPublisherSubscriberBase] Failed to get timestamp from a NITROS message (eid=10479)
[dope_decoder]: [NitrosPublisherSubscriberBase] Failed to get timestamp from a NITROS message (eid=10504)

The “/poses” topic does not contain any poses of the ketchup bottle and looks like that:
sec: 0
nanosec: 0
frame_id: camera

The isaac_ros_dope node starts without any errors and when I run the tests with “colcon test --executor sequential” I do not receive any errors as well.

I have followed the instructions provided in the GitHub repository for the package (GitHub - NVIDIA-ISAAC-ROS/isaac_ros_pose_estimation: Deep learned, hardware-accelerated 3D object pose estimation) and I am using the Isaac ROS Dev Docker images. Until replaying the bag everything looks fine.

Some information about my system:
OS: Ubuntu 22.04
GPU: NVIDIA GeForce RTX 3070 Laptop GPU
Driver version: 525.85.05
CUDA version: 12.0
Docker version: 23.0.1
Nvidia-container-toolkit is installed.

I would appreciate any guidance on resolving this error or suggestions on what I may have missed during the setup process.

Thank you for your help.

Solved with Inference result not shown · Issue #13 · NVIDIA-ISAAC-ROS/isaac_ros_pose_estimation · GitHub

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.