Error when executing nvidia-smi

Hi,
I am trying to execute Mlperf benchmark. For that I have cloned github link of mlcommons and installed docker and cuda from it.
After that when I tried to check nvidia details using “nvidia-smi” command, error encountered as follows.

ramya@moore:~/mlperf/training/object_detection$ nvidia-smi
Failed to initialize NVML: Driver/library version mismatch NVML library version: 545.23

and there is no libnvidia-ml.so file in system.

Please help me to resolve this issue.

Thank you
Ramya