Error when loading URDF for custom end effectors

I was trying to change the franka_hand to my custom end effector, by modifying the official URDF file franka_panda.urdf. I tried the following code

 roslaunch urdf_tutorial display.launch model:='$(find franka_description)/robots/franka_panda_suction.urdf'

and the visualization result in rviz was just right, shown in gym_endeffector.jpg in this link.

However, I tried to load the same URDF file through running the official, the visualization result was totally different this time.

The problem seems to be non-correspondence in coordinate frame orientations between Isaac Gym and the .stl files. I opened the .stl file of my custom end effector in Solidworks, shown in sw_endeffector.jpg in the same link above (sorry about the restrictions to new users, more than 1 link is not allowed…). The x-axis and y-axis were laid on the top surface, while the z-axis pointed inside the end effector. The axis directions were the same as rviz, but different from Isaac Gym.

Does anyone know the reason, and how could I solve it?