Error when run deepstream_python_apps/apps/deepstream-imagedata-multistream with custom rtsp

• Hardware Platform (Jetson / GPU) RTX 3060
• DeepStream Version 6.1
• JetPack Version (valid for Jetson only)
• TensorRT Version 8.4.3-1+cuda11.6
• NVIDIA GPU Driver Version (valid for GPU only) 510.85.02
• Issue Type( questions, new requirements, bugs) bugs
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)

When I run command python3 rtsp:// frame it produces below issues


I followed the instruction here, just replace the rtsp by my rtsp and the issues appeared, I don’t know why

Could anyone help? Thanks in advanced

Any update on this?

It failed at mkdir, it looking for directory “rtsp://***”, please check your script.

I used the same script as here. I didn’t change anything in the script, so why did it fail?

Please share the command you used.

I used this command

Please check your envrionments and do triage. i can run success using this app.

It’s so strange that when I run command python3 rtsp:// rtsp:// frames as instructed here, it run okay. But then I run this command python3 rtsp:// frame the bug still persists

There is no update from you for a period, assuming this is not an issue anymore.
Hence we are closing this topic. If need further support, please open a new one.

How about quoted rtsp://

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.