Error when running Moveit2 Tutorial with IsaacSim 4.0.0

Hi,

I am trying to run this example: MoveIt 2 — Omniverse IsaacSim latest documentation

However, am getting the following error:

2024-06-26 00:41:53 [145,390ms] [Error] [omni.graph.core.plugin] /ActionGraph/ArticulationController: [/ActionGraph] OmniGraph Error: No robot prim found for the articulation controller
(from compute() at line 95 in /isaac-sim/exts/omni.isaac.core_nodes/omni/isaac/core_nodes/ogn/python/nodes/OgnIsaacArticulationController.py)

The same procedure (How To Command Simulated Isaac Robot — MoveIt Documentation: Rolling documentation) works well with IsaacSim 2023.1.1.

Was there changes that I should make to the code when migrating from 2023.1.1 to 4.0.0?

Thanks!

Hi Helen. There are some required changes to moveit2_tutorials that should be merged soon.

In the meantime, you could use this branch for compatibility with Isaac Sim 4.0. Sorry for the inconvenience.

The required changes have been merged into the main branch of moveit2_tutorials, so it’s no longer necessary to use a special branch for compatibility with Isaac Sim 4.0.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.