Error when running the command to launch the deepstream-l4t image From (NGC) setting different --net parameter (not host)

Hardware Platform (Jetson / GPU)
Jetson NX

• DeepStream Version

• JetPack Version (valid for Jetson only)

• TensorRT Version

• Issue Type( questions, new requirements, bugs)
After setting

export DISPLAY=:0 or 1


Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 510mm x 290mm
   1920x1080     60.00*+  59.95  
   1440x900      59.89  
   1280x1024     60.00  
   1280x800      59.81  
   1152x864      75.00  
   1024x768      70.07    60.01  
   800x600       60.32    56.25  
   720x400       70.04  
   640x480       67.06    59.94  
DP-0 disconnected (normal left inverted right x axis y axis)

it seems correct.
Then I tried to run --net=my-net

sudo docker run -it --rm --net=my-net03_default --runtime nvidia --device=/dev/video0:/dev/video0 -e DISPLAY=$DISPLAY -w /opt/nvidia/deepstream/deepstream-5.1 -v /tmp/.X11-unix/:/tmp/.X11-unix

Here is the docker network

docker network ls
NETWORK ID     NAME                       DRIVER    SCOPE
e3f32f59cafa   bridge                     bridge    local
5a6f24359b00   host                       host      local
e5f39685296f   my-net01_default           bridge    local
e1dc5d5f0fed   my-net02                   bridge    local
2a666b3a6d39   my-net03_default           bridge    local
317eb9706394   none                       null      local

then when I tried to run test4 app

deepstream-test4-app -i /opt/nvidia/deepstream/deepstream-5.1/samples/streams/sample_720p.h264 -p /opt/nvidia/deepstream/deepstream-5.1/lib/ --conn-str=";9092" --topic=topic01 -s 0

got error

nvbuf_utils: Could not get EGL display connection
One element could not be created. Exiting.

If I set --net=host , all works. But when I need to change to another docker network, it’ll cause the error (I want to make this container can communicate with others, that why I want to try to change the --net, even I will change --net to overlay network type)

Is there any comment on this?

I think it should be more related to docker other than deepstream