Error when setting up blendShape solver

Hi there. I have completed the skin mesh fitting and transferred the face animations from mark to my face mesh successfully. i then used ‘blendshape generation’ and exported it to create a _usdSkel.usd file. I then imported this file into my project. I then Asigned the input anim mesh(the mesh which i transferred onto) and the Blenshape mesh(the one i just imported). But when i click ‘setup blendShape solve’ I get this error: 2023-07-18 15:44:38 [Warning] [omni.deform.shared.scripts.utils] Could not find the output point attribute on Node(“/World/LazyGraph/chomper_low_001mesh_020__Audio2Face_EX_result_Visualizer”).
Any help would be very much appreciated. Thanks.

I just tried following this tutorial. So I was using the two versions of mark which were included with the software, one with the animation and one with the blend shapes and when i tried to set up the blendShape solver i got this message:

2023-07-19 15:43:45 [Warning] [omni.usd] Warning (secondary thread): in ProcessPropertyChange at line 519 of C:\b\w\ca6c508eae419cf8\USD\pxr\usdImaging\usdSkelImaging\skeletonAdapter.cpp – Unhandled ProcessPropertyChange callback for cachePath </World/male_bs_46/joint1/bs_anim> in UsdSkelImagingSkelAdapter.

But the animation is transferred. When I do the same using my own models I get the same error but the animation is not transferred. Anyone have any idea why this could be? Thanks.

Ive just tried the same process using the Mark model instead of my own. I imported it into blender and deleted all the shapekeys and then exported the USD(after setting up the face as a dynamic object). I then openeed the generated project om audio2face and did a character transfer from the version of mark with an animation. I then exported the blendshapes from the new model. I then imported this new model with the newly added blenshapes back into audio2face. i then did the blenshape conversion and it worked. So for some reason I can get it to work when using the mark model but not my own. One thing I have noticed is that when I import my model(the one with blenshapes) into the scene, its really small and I have to scale it up. The mark model was exactly the same so i just had to move it to the side. I cant figure out why its doing this but Im sure it must have something to do with why I cant sucessfully copy the animation over to the blendShape model…Any helo would be massively appreciated as I feel like i am so close and this workflow would be fantastic for the game im working on but need to get the animations working on a model with blenshapes.

Ok so I finally got it working. I’m not sure exacly what it was but i think it had something to do with the models transforms. I positioned my own models head so that it matched the position of marks and then reset the transforms so that the position was at zero(it was quite heavily offset in the z place). I then went through the whole process again and this time the model with the blendshapes when imported was not tiny, so didnt need resizing. And yes, finally its now working. Hopefully this conversation with myself might come in useful for anyone expereiencing the same problem.

It sounds like the scale of your model is a little too different from Audio2Face’s template models.
What you did is a good solution.
You can also change BlendShapeSolver parameters to achieve the same thing.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.