Error when trying to compile on nvidia xavier AGX


I’m having the following error when a tried to compile grid_map_core ros package in the NVIDIA AGX using Jetpack 4.6.

catkin_make install -j1 -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/home/nvidia/workspace/install -DCATKIN_WHITELIST_PACKAGES=“grid_map_core” -DCMAKE_C_COMPILER=/usr/bin/gcc-6
Base path: /home/nvidia/workspace
Source space: /home/nvidia/workspace/src
Build space: /home/nvidia/workspace/build
Devel space: /home/nvidia/workspace/devel
Install space: /home/nvidia/workspace/install

Running command: “make cmake_check_build_system” in “/home/nvidia/workspace/build”

Running command: “make install -j1” in “/home/nvidia/workspace/build”

Scanning dependencies of target grid_map_core
[ 6%] Building CXX object grid_map/grid_map_core/CMakeFiles/grid_map_core.dir/src/Polygon.cpp.o
c++: internal compiler error: Segmentation fault (program cc1plus)
Please submit a full bug report,
with preprocessed source if appropriate.
See file:///usr/share/doc/gcc-6/README.Bugs for instructions.
grid_map/grid_map_core/CMakeFiles/grid_map_core.dir/build.make:158: recipe for target ‘grid_map/grid_map_core/CMakeFiles/grid_map_core.dir/src/Polygon.cpp.o’ failed
make[2]: *** [grid_map/grid_map_core/CMakeFiles/grid_map_core.dir/src/Polygon.cpp.o] Error 4
CMakeFiles/Makefile2:632: recipe for target ‘grid_map/grid_map_core/CMakeFiles/grid_map_core.dir/all’ failed
make[1]: *** [grid_map/grid_map_core/CMakeFiles/grid_map_core.dir/all] Error 2
Makefile:140: recipe for target ‘all’ failed
make: *** [all] Error 2

When i use the jetpack 4.5.1 works. Anybody had the same problem?

Have reference to below topic.

Thanks for the answer. The first link worked!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.